This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 436682 - No output on surround channel when pulseaudio is enabled
No output on surround channel when pulseaudio is enabled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 04:30 EDT by Tim Wegener
Modified: 2008-03-29 02:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-28 16:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Wegener 2008-03-09 04:30:45 EDT
Description of problem:
If pulseaudio is enabled, when audio is played no sound is output through the
surround channels in most apps (amarok, exaile, etc.)

Version-Release number of selected component (if applicable):
pulseaudio-0.9.8-5.fc8

How reproducible:
Always. (Note that it is a pain to disable/enable pulseaudio. Is there a simple
option somewhere to do this?

Steps to Reproduce:
1. Play audio in amarok or exaile (any other music player)
2. Notice the lack of output through the surround channel
3. Disable pulseaudio (which stops amarok working regardless, but exaile still
plays sound)
4. Play audio in exaile and notice that sound is output through the surround
channel.
  
Actual results:
No output from surround channel when pulseaudio is active.

Expected results:
Audible audio output from the surround channel when playing music.


Additional info:
This is a significant problem for me, since my main front channels pick up
interference (apparently from the wifi card), so I use the surround output which
is clean. 
This worked fine in previous versions of Fedora since they didn't use pulse audio.
Comment 1 Tim Wegener 2008-03-09 04:49:10 EDT
Note that the following does output sound on the surround channels, even when
pulse-audio is running:
speaker-test -Dplug:surround51 -c6 -l1 -twav

When I mentioned disabling pulseaudio above, this involved killing the
pulseaudio process. To re-enable it I had to chown /tmp/pulse-username to
username and then run 'pulseaudio -D'. 

Also note that in PulseAudio Manager there is only one sink present:
alsa_output.pci_1102_2_alsa_playback_0
ALSA PCM on front:0 (ADC Capture/Standard PCM Playback) via DMA

Comment 2 Lennart Poettering 2008-03-28 16:48:45 EDT
To enable surround support in PA, edit /etc/pulse/daemon.conf and set the
default number of channels to 6.
Comment 3 Tim Wegener 2008-03-29 00:51:11 EDT
This did not work. Please re-open the bug.

Here are the results from setting 'default-sample-channels = 6' in
/etc/pulse/daemon.conf
(BTW, why isn't the selection of the number of channels to use available from
the GUI?)

# pkill pulseaudio
# pulseaudio
W: main.c: This program is not intended to be run as root (unless --system is
specified).
W: alsa-util.c: Device hw:1 doesn't support 44100 Hz, changed to 16000 Hz.
W: alsa-util.c: Device hw:1 doesn't support 6 channels, changed to 1.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL surround51:0
ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition
'cards.EMU10K1.pcm.surround71.0:CARD=0'
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned
error: No such file or directory
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
ALSA lib setup.c:96:(snd_sctl_install) Cannot lock ctl elem
W: alsa-util.c: Device hw:0 doesn't support 6 channels, changed to 2.
Comment 4 Tim Wegener 2008-03-29 02:05:04 EDT
Correction: that does work for me now. For the situation described in the
previous comment I was running pulseaudio as root. Doing 'chown -R username
/tmp/pulse-username' and, as the normal user, doing 'pulseaudio -D' did the trick. 
However, the user experience is pretty poor overall. Summary of problems:
 * there is no straightforward way to restart pulseaudio
 * there is no way to turn on 6 channel (i.e. 5.1 channel) support from the GUI
 * volume controls in kmix now appear to have no effect (at least Master, PCM,
Wave Surround)
 * it is inconvenient to navigate into PulseAudio Volume Control everytime one
wants to change the volume
 * in PulseAudio Volume Control there is no option to lock left+right pairs
within a 6 channel setup (it's either all six channels locked together, or all
six separate) (cf alsamixergui behaviour)

Note You need to log in before you can comment on or make changes to this bug.