Bug 436690 - Latitude D505 / 855GM: unable to get 1400x1050
Latitude D505 / 855GM: unable to get 1400x1050
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 08:31 EDT by Patrick C. F. Ernzer
Modified: 2008-03-21 14:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-21 14:29:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball with the config and the logs of the 4 tests (14.88 KB, application/octet-stream)
2008-03-09 08:31 EDT, Patrick C. F. Ernzer
no flags Details
Xorg.0.log-i810 from attachment 297354 (67.44 KB, text/plain)
2008-03-10 14:01 EDT, Matěj Cepl
no flags Details
Xorg.0.log-intel from attachment 297354 (38.28 KB, text/plain)
2008-03-10 14:02 EDT, Matěj Cepl
no flags Details
Xorg.0.log-intelandmodeline from attachment 297354 (38.24 KB, text/plain)
2008-03-10 14:02 EDT, Matěj Cepl
no flags Details
Xorg.0.log-intelandscreendefined from attachment 297354 (38.24 KB, text/plain)
2008-03-10 14:02 EDT, Matěj Cepl
no flags Details
xorg.conf-i810 from attachment 297354 (1.27 KB, text/plain)
2008-03-10 14:02 EDT, Matěj Cepl
no flags Details
xorg.conf-intel from attachment 297354 (1.27 KB, text/plain)
2008-03-10 14:02 EDT, Matěj Cepl
no flags Details
xorg.conf-intelandmodeline from attachment 297354 (1.63 KB, text/plain)
2008-03-10 14:03 EDT, Matěj Cepl
no flags Details
xorg.conf-intelandscreendefined from attachment 297354 (1.45 KB, text/plain)
2008-03-10 14:03 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2008-03-09 08:31:04 EDT
Description of problem:
I seem to be unable to get 1400x1050 on the build-in laptop screen. It's a
Latitude D505 (BIOS A09), but I guess what matters here is:
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.1-7.fc8

How reproducible:
always

Steps to Reproduce:
0. set 915resolution up so that 1400x1050 is listed as mode 3c
1. remove /etc/X11/xorg.conf
2. run s-c-display
3. select i810 driver
4. startx (selecting Quit when told that running X as root is very dumb indeed)
5. display comes up at 1024
6. re-do steps 1-4 but with intel driver
  
Actual results:
xorg will only come up at 1024x768.
 - i810 driver nags that it just does not know 1400x1050 and the relevant modes
show up as follows "Mode: 3c (0x0)" in the log
 - intel driver nags about sync out of range
 - explicitly adding the monitor type in s-c-display dos not help
 - making a modeline with gtf does not help (it seems to be ignored)




Expected results:
after setting the mode with 915resolution I was expecting the machine to be able
to use the mode

Additional info:
# 915resolution -l
Intel 800/900 Series VBIOS Hack : version 0.5.3

Chipset: 855GM
BIOS: TYPE 1
Mode Table Offset: $C0000 + $29f
Mode Table Entries: 39

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1400x1050, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1400x1050, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1400x1050, 32 bits/pixel


tarball with configs and logs attached
Comment 1 Patrick C. F. Ernzer 2008-03-09 08:31:04 EDT
Created attachment 297354 [details]
tarball with the config and the logs of the 4 tests
Comment 2 Patrick C. F. Ernzer 2008-03-09 08:46:19 EDT
some additions:
  - with BIOS A11 (latest) and the i810 driver I get a bar of about 1 cm of
garbled pixels at the top of the display and the rest is shifted down by that
1cm. Resolution is still 1024x768
  - with BIOS A11 (latest) and the intel driver I get exactly the same results
as with BIOS A09
  - to be ultra-paranoid, for all these tests grub was configured as follows
    * splashimage commented out
    * hiddenmenu commented out
    * kernel lines modified to not use rhgb
  - and the default runlevel for all these tests was 3.
so the system comes up in plain old text mode
Comment 3 Matěj Cepl 2008-03-10 14:01:48 EDT
Created attachment 297475 [details]
Xorg.0.log-i810 from attachment 297354 [details]
Comment 4 Matěj Cepl 2008-03-10 14:02:02 EDT
Created attachment 297476 [details]
Xorg.0.log-intel from attachment 297354 [details]
Comment 5 Matěj Cepl 2008-03-10 14:02:12 EDT
Created attachment 297477 [details]
Xorg.0.log-intelandmodeline from attachment 297354 [details]
Comment 6 Matěj Cepl 2008-03-10 14:02:28 EDT
Created attachment 297478 [details]
Xorg.0.log-intelandscreendefined from attachment 297354 [details]
Comment 7 Matěj Cepl 2008-03-10 14:02:40 EDT
Created attachment 297479 [details]
xorg.conf-i810 from attachment 297354 [details]
Comment 8 Matěj Cepl 2008-03-10 14:02:50 EDT
Created attachment 297480 [details]
xorg.conf-intel from attachment 297354 [details]
Comment 9 Matěj Cepl 2008-03-10 14:03:02 EDT
Created attachment 297481 [details]
xorg.conf-intelandmodeline from attachment 297354 [details]
Comment 10 Matěj Cepl 2008-03-10 14:03:13 EDT
Created attachment 297482 [details]
xorg.conf-intelandscreendefined from attachment 297354 [details]
Comment 11 Patrick C. F. Ernzer 2008-03-21 14:29:25 EDT
gaaaah, my bad!

The machine in question is one of the few D505 that has a 14.1” XGA (1024x768)
instead of a SXGA+ (1400x1050) display.

That's what I get for offering to install somebody's notebook without looking at
the existing Win installation to double check the screen resolution.

Note You need to log in before you can comment on or make changes to this bug.