Bug 436708 - graphics garbage and system lockup with intel 945GM (MacBook)
graphics garbage and system lockup with intel 945GM (MacBook)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 14:39 EDT by Karl Lattimer
Modified: 2008-11-02 19:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-02 19:48:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Lattimer 2008-03-09 14:39:10 EDT
Description of problem:
After upgrading to rawhide the intel 945GM graphics card in my macbook 13 will
garble the screen and lock the system when logging into GNOME. Could be related
to a misbehaving applet as X is fine up to a certain point, and works perfectly
all the way through RHGB

How reproducible:
Always

Steps to Reproduce:
1. Start computer
2. Log into GDM
3. Wait for crash to occur
  
Actual results:
Screen is garbled, cursor no longer moves, caps lock button fails to light up,
so the system has panicked in some way

Expected results:
GNOME session to finish starting.

Additional info:
I have a bunch of things in my session startup including seahorse, and possibly
others, this could be due to nm-applet as that  is the last thing to be
displayed every time it happens. Could be related to automount as a bunch of
errors are thrown out to /var/log/messages just prior to the crash.
Comment 1 Matěj Cepl 2008-03-10 07:23:35 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Karl Lattimer 2008-03-13 22:24:39 EDT
I've just been toying with this, and started bits of gnome piece by piece. Its
most certainly network manager applet starting up that causes it to crash.

This is a macbook 13 with an atheros wifi card. I suppose its possible something
is wrong with the ath5k driver which appears to be present on rawhide
Comment 3 Karl Lattimer 2008-03-13 22:25:36 EDT
P.S. can we change the component to network manager I don't think this is
related to X anymore, sorry for the misfiling this is probably some kind of
network manager panic. 
Comment 4 Dan Williams 2008-03-14 17:28:42 EDT
Karl; can you get the output of lspci, and are you using the ath5k driver or
madwifi?
Comment 5 Karl Lattimer 2008-04-11 01:36:00 EDT
Sorry for the delay, I'm using the ath5k driver its not functional though :/
can't seem to scan for networks :(

lspci relevant line;
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg
Wireless PCI Express Adapter (rev 01)

Also this bug is no longer exhibited, in that it doesn't crash my system...
Comment 6 Bug Zapper 2008-05-14 01:53:23 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Dan Williams 2008-11-02 16:53:08 EST
does this still happen?  If so, what kernel version are you running?
Comment 8 Karl Lattimer 2008-11-02 19:10:19 EST
Nope, no longer an issue, close it :)

Note You need to log in before you can comment on or make changes to this bug.