Bug 436713 - ntpd: getaddrinfo: "::1" invalid host address, ignored
ntpd: getaddrinfo: "::1" invalid host address, ignored
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-09 16:30 EDT by Robert Scheck
Modified: 2012-11-19 09:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 16:01:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2008-03-09 16:30:12 EDT
Description of problem:
Restarting/starting ntpd brings the following strange message into log:
Mar 9 21:27:39 tux ntpd[10545]: getaddrinfo: "::1" invalid host address, ignored
To me it looks like the IPv6 support is somehow damaged...

Version-Release number of selected component (if applicable):
ntp-4.2.4p4-4

How reproducible:
Everytime, see above.

Expected results:
No strange message further on, looks like IPv6 support is somehow damaged.
Comment 1 Miroslav Lichvar 2008-03-10 16:01:14 EDT
Hm, glibc-headers now require _GNU_SOURCE for in6_pktinfo struct. Should be
fixed in ntp-4.2.4p4-5.fc9.

Thanks for the report.
Comment 2 Pavel Šimerda (pavlix) 2012-11-19 09:34:05 EST
Are you sure this is not due to the still unresolved getaddrinfo GLIBC bug?

https://bugzilla.redhat.com/show_bug.cgi?id=808147

Note You need to log in before you can comment on or make changes to this bug.