Bug 436730 - X crashes when using QT based apps
X crashes when using QT based apps
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-09 22:01 EDT by Rene Rask
Modified: 2008-03-17 13:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-17 13:22:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg crash log (24.00 KB, text/plain)
2008-03-09 22:11 EDT, Rene Rask
no flags Details

  None (edit)
Description Rene Rask 2008-03-09 22:01:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20080201 Firefox/

Description of problem:
X starts normally and works normally until i try to use apps which use QT libraries. 
The only app I have tried are nxclient and virtualbox gui. I don't use other qt based apps.
This happens on 2 of my laptops which both have nvidea cards and use the open drivers. Can't test on my tablet with an intel chipset since X is broken on intel hardware at the moment.
I tried using the vesa driver which gives the same result.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. login to X
2. start nxclient or VirtualBox gui.

Actual Results:
The program launces and will crash X when I interact with it. Sometimes just moving the pointer over the app will crash X.
nxclient crashes when I press "connect" which should launch a fullscreen window.

Expected Results:
It shouldn't crash.

Additional info:
Comment 1 Rene Rask 2008-03-09 22:11:52 EDT
Created attachment 297398 [details]
Xorg crash log
Comment 2 Rene Rask 2008-03-15 07:35:20 EDT
This has gone away with the latest rawhide update. 
Feel free to close this bug as I can no longer reproduce the error.
Comment 3 Matěj Cepl 2008-03-17 13:22:34 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.