Bug 436744 - sound not working at all
sound not working at all
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 03:26 EDT by Richard Hally
Modified: 2008-03-12 20:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 06:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
terminal commands and output (10.63 KB, text/plain)
2008-03-10 09:22 EDT, Richard Hally
no flags Details

  None (edit)
Description Richard Hally 2008-03-10 03:26:19 EDT
Description of problem:
On Sat, 2008-03-08 at 18:02 -0500, Richard Hally wrote:
 On an updated rawhide system, there is no sound either from the "system sounds" 
 or from playing a CD nor from the sound card configuration GUI.
 Below at the bottom are the message from /var/log/messages that seem to be related.
> > 

Version-Release number of selected component (if applicable):

 alsa-lib-1.0.16-2.fc9.i386
 alsa-plugins-pulseaudio-1.0.15-4.fc9.i386
 alsa-utils-1.0.16-2.fc9.i386
 bluez-utils-alsa-3.26-1.fc9.i386
 alsa-plugins-pulseaudio-1.0.15-4.fc9.i386
 gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.i386
 pulseaudio-0.9.8-9.fc9.i386
 pulseaudio-core-libs-0.9.8-9.fc9.i386
 pulseaudio-esound-compat-0.9.8-9.fc9.i386
 pulseaudio-libs-0.9.8-9.fc9.i386
 pulseaudio-libs-glib2-0.9.8-9.fc9.i386
 pulseaudio-module-gconf-0.9.8-9.fc9.i386
 pulseaudio-module-x11-0.9.8-9.fc9.i386
 pulseaudio-utils-0.9.8-9.fc9.i386 
 
How reproducible:
every time

Steps to Reproduce:
1.boot system
2.try to play a CD with rhythembox or try the soundcard configuration test.
3.
  
Actual results:
no sound

Expected results:
play sound

Additional info:
the hardware works--Fedora 8 on the same box works.

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
    Subsystem: Biostar Microtech Int'l Corp Unknown device 820f
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at fdff8000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel <?>
    Capabilities: [130] Root Complex Link <?>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

from /var/log/messages:
Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1813: chipset
global capabilities = 0x4401
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:749:
codec_mask = 0x4
 Mar  8 16:54:49 new3Linux kernel: hda_codec: Unknown model for ALC662, trying
auto-probe from BIOS...
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Surround Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Center Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave LFE Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Side Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Headphone Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Speaker Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Mono Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Line-Out Playback Volume, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Surround Playback Switch, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Center Playback Switch, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave LFE Playback Switch, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Side Playback Switch, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Speaker Playback Switch, skipped
 Mar  8 16:54:49 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Mono Playback Switch, skipped
 Mar  8 16:54:49 new3Linux kernel: device-mapper: uevent: version 1.0.3
> > > -------------------------
 
 Mar  8 16:55:37 new3Linux pulseaudio[2793]: pid.c: Stale PID file, overwriting.
 Mar  8 16:55:37 new3Linux pulseaudio[2793]: main.c: setrlimit(RLIMIT_NICE, (31,
31)) failed: Operation not permitted
 Mar  8 16:55:37 new3Linux pulseaudio[2793]: main.c: setrlimit(RLIMIT_RTPRIO,
(9, 9)) failed: Operation not permitted
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x4400, fragsize=0x1100, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x6, stream=0x5, channel=0, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x4400, fragsize=0x1100, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x6, stream=0x5, channel=0, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x4400, fragsize=0x1100, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x9, stream=0x1, channel=0, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x4400, fragsize=0x1100, format=0x4011
 Mar  8 16:55:37 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x9, stream=0x1, channel=0, format=0x4011
> > >hda_codec_setup_stream: NID=0x9, stream=0x0, channel=0, format=0x0
 Mar  8 16:55:38 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x9, stream=0x0, channel=0, format=0x0
 Mar  8 16:55:38 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x0, channel=0, format=0x0
 Mar  8 16:55:38 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x6, stream=0x0, channel=0, format=0x0
 Mar  8 16:55:38 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x0, channel=0, format=0x0
 Mar  8 16:55:39 new3Linux gconfd (richard-2723): Resolved address
"xml:readwrite:/home/richard/.gconf" to a writable configuration source at
position 0
 Mar  8 16:55:40 new3Linux hcid[2201]: Default passkey agent (:1.30,
/org/bluez/passkey) registered
 Mar  8 16:55:40 new3Linux hcid[2201]: Default authorization agent (:1.30,
/org/bluez/auth) registered
 Mar  8 16:55:40 new3Linux pulseaudio[2793]: module-x11-xsmp.c: X11 session
manager not running.
 Mar  8 16:55:40 new3Linux pulseaudio[2793]: module.c: Failed to load  module
"module-x11-xsmp" (argument: ""): initialization failed.
> > > --------------------------------
 
 Mar  8 16:56:42 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x4400, fragsize=0x1100, format=0x4011
 Mar  8 16:56:42 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x6, stream=0x5, channel=0, format=0x4011
 Mar  8 16:56:42 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011
 Mar  8 16:56:42 new3Linux kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x4400, fragsize=0x1100, format=0x4011
 Mar  8 16:56:42 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x6, stream=0x5, channel=0, format=0x4011
 Mar  8 16:56:42 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011
 Mar  8 16:56:56 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x0, channel=0, format=0x0
 Mar  8 16:56:56 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x6, stream=0x0, channel=0, format=0x0
 Mar  8 16:56:56 new3Linux kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x0, channel=0, format=0x0
 
>
Comment 1 Martin Stransky 2008-03-10 07:06:11 EDT
Sound is configured by pulseaudio now. Quite sure not the alsa-lib bug.
Comment 2 Lubomir Kundrak 2008-03-10 07:20:16 EDT
Quite sure Martin didn't guess the right component this time :)

This looks like a kernel ALSA problem.

Please try the following:

1.) Does sound work without pulseaudio?
$ aplay -d hw:0 /usr/share/sounds/startup3.wav 
do you hear a (remarkably awful) sound?

2.) What warnings does pulseaudio output when being verbose?
$ pulseaudio -k
kill the runnning daemon
$ pulseaudio -vvv
run it being very verbose
Comment 3 Richard Hally 2008-03-10 09:21:34 EDT
no sound from the aplay command.
creating an attachment with the cut and paste from the pulseaudio output.

p.s. I checked that aplay command by booting the Fedora 8 partition on the same
box and it plays that ugly sound.
Comment 4 Richard Hally 2008-03-10 09:22:57 EDT
Created attachment 297427 [details]
terminal commands and output
Comment 5 Lubomir Kundrak 2008-03-11 10:08:05 EDT
I am stupid. I meant aplay -D hw, not (lowercase) -d.
Please pardon me and repeat that.
Comment 6 Richard Hally 2008-03-11 19:49:58 EDT
[richard@new3Linux ~]$ aplay -D hw:0 /usr/share/sounds/startup3.wav
Playing WAVE '/usr/share/sounds/startup3.wav' : Signed 16 bit Little Endian,
Rate 44100 Hz, Stereo
[richard@new3Linux ~]$ 

still no sound.
Comment 7 Lubomir Kundrak 2008-03-12 04:34:26 EDT
So it looks like this is really not a pulseaudio thing.
I assume you looked at all ALSA controls that you haven't audio muted.

May I ask -- is there a difference in what goes to the kernel message buffer
(dmesg) when you do the aplay above on F8 and Rawhide?

Could you please add version numbers of kernels where sound works and where it
doesn't to this report, as it will likely get reassigned to kernel?

Thanks!
Comment 8 Richard Hally 2008-03-12 06:30:52 EDT
this is weird -- after booting F8 and then booting back to rawhide sound now
works on the rawhide install as well. 
We can close this bug. thanks for looking at it. I appreciate your work.
Comment 9 Tore H. Larsen 2008-03-12 19:50:39 EDT
Had to change udev rules to get sound working. Added MODE="0666" to 40-alsa.rules

[root@bgo-s-101 ~]# more /etc/udev/rules.d/40-alsa.rules 
# do not edit this file, it will be overwritten on update

KERNEL=="controlC[0-9]*",	NAME="snd/%k",	MODE="0666"
KERNEL=="hwC[D0-9]*",		NAME="snd/%k",	MODE="0666"
KERNEL=="pcmC[D0-9cp]*",	NAME="snd/%k",	MODE="0666"
KERNEL=="midiC[D0-9]*",		NAME="snd/%k",	MODE="0666"
KERNEL=="timer",		NAME="snd/%k",	MODE="0666"
KERNEL=="seq",			NAME="snd/%k",	MODE="0666"
KERNEL=="mixer0",		SYMLINK+="mixer",	MODE="0666"
KERNEL=="dsp0",			SYMLINK+="dsp",	MODE="0666"
KERNEL=="audio0",		SYMLINK+="audio",	MODE="0666"

Comment 10 Tore H. Larsen 2008-03-12 19:55:21 EDT
My laptop is T61p, and I had same hda_codec errors and couldn't adjust sound
from Gnome volume applet until above workaround. But I still see do see errors
in syslog

Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_intel.c:1813: chipset
global capabilities = 0x4401
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_intel.c:749: codec_mask
= 0x3
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:2239:
hda_codec: model 'thinkpad' is selected for config 17aa:0 (Lenovo Thinkpad)
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Mono Playback Volume, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Front Mic Playback Volume, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave CD Playback Volume, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Docking Mic Playback VolumeBeep Playback Volume, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Front Playback Switch, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Surround Playback Switch, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Center Playback Switch, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave LFE Playback Switch, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Side Playback Switch, skipped
Mar 13 00:40:52 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:1076: Cannot
find slave Mono Playback Switch, skipped
Mar 13 00:41:21 bgo-s-101 kernel: ALSA sound/pci/hda/hda_intel.c:1293:
azx_pcm_prepare: bufsize=0x1800, fragsize=0x800, format=0x4011
Mar 13 00:41:21 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x5, channel=0, format=0x4011
Mar 13 00:41:21 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x4, stream=0x5, channel=0, format=0x4011
Mar 13 00:41:21 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x4, stream=0x0, channel=0, format=0x0
Mar 13 00:41:21 bgo-s-101 kernel: ALSA sound/pci/hda/hda_codec.c:686:
hda_codec_setup_stream: NID=0x2, stream=0x0, channel=0, format=0x0

Suggestions?
Comment 11 Tore H. Larsen 2008-03-12 20:04:47 EDT
[torel@bgo-s-101 ~]$ pulseaudio -k
E: main.c: Failed to kill daemon.
[torel@bgo-s-101 ~]$ pulseaudio -vvv
I: main.c: PolicyKit refuses acquire-high-priority privilige.
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority
scheduling.
I: core-util.c: Successfully gained nice level -11.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of
'/usr/lib64/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0
sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0
"alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0" with sample spec "s16le
2ch 44100Hz"
I: source.c: Created source 0
"alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor" with sample
spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: ALSA device lacks independant volume controls for each channel,
falling back to software volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0
sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0
source_name=alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1
"alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0" with sample spec "s16le
2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware
volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0
source_name=alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0").
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_hw_specific_0
D: module-hal-detect.c: Not loaded device
/org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module-volume-restore.c: starting with empty ruleset.
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
D: module-default-device-restore.c: No previous default sink setting, ignoring.
D: module-default-device-restore.c: No previous default source setting, ignoring.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink
alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Source
alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source
alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib64/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #9; argument: "").
D: cli-command.c: Checking for existance of
'/usr/lib64/pulse-0.9/modules/module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus,
path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source
alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0 idle for too long,
suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source
alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor idle for too
long, suspending ...
I: module-suspend-on-idle.c: Sink
alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0 idle for too long,
suspending ...
I: module-alsa-sink.c: Device suspended...
I: client.c: Created 0 "EsounD client (UNIX socket client)"
I: client.c: Created 1 "EsounD client (UNIX socket client)"
I: client.c: Created 2 "EsounD client (UNIX socket client)"
Comment 12 Lubomir Kundrak 2008-03-12 20:26:05 EDT
(In reply to comment #9)
> Had to change udev rules to get sound working. Added MODE="0666" to 40-alsa.rules

Install this, or fix your desktop environment configuration
https://admin.fedoraproject.org/updates/F8/FEDORA-2008-2246

(In reply to comment #10)
> My laptop is T61p, and I had same hda_codec errors and couldn't adjust sound
> from Gnome volume applet until above workaround. But I still see do see errors
> in syslog

What kernel?

> Suggestions?

My only suggestion here is not to spam closed bugs with non-related comments.

Note You need to log in before you can comment on or make changes to this bug.