Bug 436773 - Broken pkg-config file
Broken pkg-config file
Status: CLOSED DUPLICATE of bug 426106
Product: Fedora
Classification: Fedora
Component: pkgconfig (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 08:42 EDT by Bastien Nocera
Modified: 2009-01-16 21:34 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.7.5-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 21:34:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
telepathy-glib-broken-pkgconfig.patch (566 bytes, patch)
2008-03-21 11:08 EDT, Bastien Nocera
no flags Details | Diff
bug-436773.patch (2.12 KB, patch)
2008-03-21 11:11 EDT, Bastien Nocera
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 15199 None None None Never

  None (edit)
Description Bastien Nocera 2008-03-10 08:42:16 EDT
The pkg-config file is missing Requires for glib-2.0 and dbus-glib-1

telepathy-glib-devel-0.7.5-1.fc9

make[2]: Entering directory
`/builddir/build/BUILD/gnome-phone-manager-0.50/telepathy'
gcc -DHAVE_CONFIG_H -I. -I..  -I/usr/include/telepathy-1.0  
-DGNOMELOCALEDIR=\""/usr/share/locale"\"
-DDATA_DIR="\"/usr/share/gnome-phone-manager\"" -DVERSION="\"0.50\""
-DPACKAGE="\"gnome-phone-manager\"" -I./../libgsm -I./../libgsm   -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT connection.o -MD -MP -MF
.deps/connection.Tpo -c -o connection.o connection.c
gcc -DHAVE_CONFIG_H -I. -I..  -I/usr/include/telepathy-1.0  
-DGNOMELOCALEDIR=\""/usr/share/locale"\"
-DDATA_DIR="\"/usr/share/gnome-phone-manager\"" -DVERSION="\"0.50\""
-DPACKAGE="\"gnome-phone-manager\"" -I./../libgsm -I./../libgsm   -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT connection-manager.o -MD -MP
-MF .deps/connection-manager.Tpo -c -o connection-manager.o connection-manager.c
gcc -DHAVE_CONFIG_H -I. -I..  -I/usr/include/telepathy-1.0  
-DGNOMELOCALEDIR=\""/usr/share/locale"\"
-DDATA_DIR="\"/usr/share/gnome-phone-manager\"" -DVERSION="\"0.50\""
-DPACKAGE="\"gnome-phone-manager\"" -I./../libgsm -I./../libgsm   -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT debug.o -MD -MP -MF
.deps/debug.Tpo -c -o debug.o debug.c
gcc -DHAVE_CONFIG_H -I. -I..  -I/usr/include/telepathy-1.0  
-DGNOMELOCALEDIR=\""/usr/share/locale"\"
-DDATA_DIR="\"/usr/share/gnome-phone-manager\"" -DVERSION="\"0.50\""
-DPACKAGE="\"gnome-phone-manager\"" -I./../libgsm -I./../libgsm   -O2 -g -pipe
-Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mtune=generic -MT im-channel.o -MD -MP -MF
.deps/im-channel.Tpo -c -o im-channel.o im-channel.c
In file included from im-channel.c:26:
/usr/include/telepathy-1.0/telepathy-glib/channel-iface.h:25:25: error:
glib-object.h: No such file or directory
In file included from im-channel.c:26:
/usr/include/telepathy-1.0/telepathy-glib/channel-iface.h:48: error: expected
'=', ',', ';', 'asm' or '__attribute__' before 'typedef'
/usr/include/telepathy-1.0/telepathy-glib/channel-iface.h:59: error: expected
')' before '*' token
/usr/include/telepathy-1.0/telepathy-glib/channel-iface.h:68: error: expected
specifier-qualifier-list before 'GTypeInterface'
/usr/include/telepathy-1.0/telepathy-glib/channel-iface.h:71: error: expected
'=', ',', ';', 'asm' or '__attribute__' before 'tp_channel_iface_get_type'
In file included from /usr/include/telepathy-1.0/telepathy-glib/dbus.h:25,
                 from im-channel.c:27:
/usr/include/telepathy-1.0/telepathy-glib/proxy.h:25:28: error:
dbus/dbus-glib.h: No such file or directory
In file included from /usr/include/telepathy-1.0/telepathy-glib/dbus.h:25,
                 from im-channel.c:27:
Comment 1 Brian Pepple 2008-03-10 12:18:24 EDT
the devel package already had a requires on dbus-glib-devel, but I added the
missing requires on glib2-devel in 0.7.5-2.
Comment 2 Bastien Nocera 2008-03-21 11:06:41 EDT
Still a problem in telepathy-glib-devel-0.7.5-2.fc9.i386
See:
http://koji.fedoraproject.org/koji/taskinfo?taskID=525148

It's not the package missing a requires, it's the pkg-config file not listing
its dependencies.
Comment 3 Bastien Nocera 2008-03-21 11:08:12 EDT
Created attachment 298793 [details]
telepathy-glib-broken-pkgconfig.patch

Requires.private are for requirements that aren't exposed in the headers. Glib
and dbus-glib are clearly used in the telepathy-glib-devel headers, so they
shouldn't be listed in the private section.
Comment 4 Bastien Nocera 2008-03-21 11:11:28 EDT
Created attachment 298794 [details]
bug-436773.patch

Seems I'm not allowed to commit. Please send the other patch upstream as well.
Comment 5 Brian Pepple 2008-03-24 21:43:34 EDT
Bastien, thanks for the patch.  I kicked off a build (0.7.5-4) that should fix this.

Leaving this open for now, since freedesktop.org's bugzilla seems to be down
right now, and I don't want to forget to forward this upstream.
Comment 6 Bastien Nocera 2008-03-25 14:49:47 EDT
Reassigning to pkg-config, as per upstream
Comment 7 Brian Pepple 2008-03-26 19:34:31 EDT
This is probably a duplicate of #426106.
Comment 8 Bug Zapper 2008-05-14 01:54:15 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Simon McVittie 2008-07-03 07:56:22 EDT
Your patch reverts a change we were asked to make by the pkg-config maintainer
(Tollef Fog Heen, Mithrandir in the IRC transcript linked below). The point of
Requires.private is to cut down on unnecessary library cross-linking by removing
unnecessary LDFLAGS in dependent projects.

https://bugs.freedesktop.org/show_bug.cgi?id=15199 has background for this,
including a log snippet from #telepathy in which Mithrandir asks us to use
Requires.private, and some other interesting links.

It appears that at the time I concluded that the problem was that Fedora's
pkg-config includes an early, unreviewed patch for
https://bugs.freedesktop.org/show_bug.cgi?id=4738 which breaks the functionality
we rely on. Perhaps this patch could be updated?
Comment 10 Dominik 'Rathann' Mierzejewski 2008-07-13 14:42:22 EDT
(In reply to comment #7)
> This is probably a duplicate of #426106.

I think so, too.
Comment 11 Matthias Clasen 2009-01-16 21:34:48 EST

*** This bug has been marked as a duplicate of bug 426106 ***

Note You need to log in before you can comment on or make changes to this bug.