Bug 436785 - ocaml-perl4caml need to fix '%check' section of the spec file
ocaml-perl4caml need to fix '%check' section of the spec file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ocaml-perl4caml (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
http://www.annexia.org/tmp/ocaml/ocam...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 10:17 EDT by Richard W.M. Jones
Modified: 2008-03-12 06:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 06:46:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2008-03-10 10:17:09 EDT
%check section fails if ocaml-perl4caml has been installed.
The explanation for this is in the spec file:

  %check
  # This fails if perl4caml is installed.  The bytecode programs
  # load dllperl4caml.so from OCaml's stublibs, instead of the
  # one we just built.  Since dllperl4caml.so in stublibs
  # (wrongly) lacks an rpath for libperl.so, it won't find
  # libperl.so in the obscure directory where it resides.
  # Monkeying around with LD_LIBRARY_PATH doesn't help because
  # ocamlrun uses $libdir/ocaml/ld.conf to find directories
  # containing the stublibs.
  make test ||:

It should be possible to fix this by setting an environment
variable such as CAML_LD_LIBRARY_PATH.  See section 10.3
of the manual:

  http://caml.inria.fr/pub/docs/manual-ocaml/manual024.html

Note You need to log in before you can comment on or make changes to this bug.