Bug 436805 - Please release xdvik also for F-8
Please release xdvik also for F-8
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xdvik (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 11:33 EDT by Jindrich Novy
Modified: 2013-07-02 19:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-21 12:53:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jindrich Novy 2008-03-10 11:33:30 EDT
If someone wants to use xdvi on F-8, even with TeXLive, it still installs
tetex-xdvi with a very old version of xdvik. Could you please release the new
xdvik for F-8 as well and obsolete the tetex-xdvi one?

I removed xdvik from TeXLive for F-8, because I think it would be better to
release a newer one even for F-8 :)
Comment 1 Jonathan Underwood 2008-03-11 07:19:58 EDT
OK, will do.


However, I am not sure this is the right fix to the problem that tetex-xdvi is
being installed in preference to xdvik - that tells me we've got our obsoletes
versioning wrong somewhere. Need to think about that when I have a bit of time.
Comment 2 Jindrich Novy 2008-03-11 07:42:13 EDT
The obsoletion problem is history now fortunatelly. I fixed it by the latest
tetex update. The thing is that I disabled xdvi build in F8 TeXLive, so that if
an user needs to install xdvik, the only option for him is to install old
tetex-xdvi now, since I disabled the TeXLive one in favour of your xdvik, so
that F8 users could use the latest one.
Comment 3 Jonathan Underwood 2008-03-11 07:56:05 EDT
OK, understood.

Will endeavour to get to this this evening.
Comment 4 Jonathan Underwood 2008-03-11 08:10:53 EDT
Package Change Request
======================
Package Name: xdvik
New Branches: F-8
Comment 5 Kevin Fenzi 2008-03-12 13:26:24 EDT
cvs done.
Comment 6 Jonathan Underwood 2008-03-13 21:23:38 EDT
OK, I modified the Requires and BuildRequires for F-8 and built a package:

http://koji.fedoraproject.org/koji/taskinfo?taskID=516087

However, we need to fix the following issue - it seems tetex-fonts contains some
files it shouldn't.

# rpm -Uvh xdvik-22.84.13-17.fc8.1.x86_64.rpm 
Preparing...                ########################################### [100%]
        file /usr/share/texmf/pxdvi/XDvi from install of
xdvik-22.84.13-17.fc8.1.x86_64 conflicts with file from package
tetex-fonts-3.0-44.8.fc8.x86_64
        file /usr/share/texmf/xdvi/XDvi from install of
xdvik-22.84.13-17.fc8.1.x86_64 conflicts with file from package
tetex-fonts-3.0-44.8.fc8.x86_64
Comment 7 Jonathan Underwood 2008-03-15 10:31:03 EDT
Actually, thinking more about this, Jindrich, I think we need a bit more
discussion. If you want xdvik in the F-8 repo to also work with your F-8 texlive
repo, then as well as fixing the above problem with tetex, we are going to need
to set up virtual provides in tetex to match texlive. For example, xdvik
requires kpathsea. With tetex, that means a Requires: tetex. With texlive that
means Requires: kpathsea. If we have consistent virtual Provides: tex(kpathsea)
in BOT tetex and texlive, this problem is overcome. So i think if we're going
down this road, we need to add tex virtual provides to the tetex package.
Comment 8 Jonathan Underwood 2008-03-15 10:31:54 EDT
Alternatively, we can just add Provides: kpathsea to tetex, of course.
Comment 9 Jonathan Underwood 2008-07-21 12:53:03 EDT
I guess this is no longer an issue? Closing WONTFIX - reopen if you still want
to do something about this.

Note You need to log in before you can comment on or make changes to this bug.