Bug 436809 - Rawhide .treeinfo files in install tree are missing boot ISO entry
Summary: Rawhide .treeinfo files in install tree are missing boot ISO entry
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-10 15:56 UTC by Daniel Berrange
Modified: 2013-01-10 04:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 20:16:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2008-03-10 15:56:15 UTC
Description of problem:
In Fedora 8 there were entries in the .treeinfo file for the bootable ISOs

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/i386/os/.treeinfo

In Fedora 9 rawhide, these entries are missing

http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/.treeinfo

This is probably the result of boot.iso / diskboot.iso being renamed/merged into
 netinst.iso

The virt-install/virt-manager tools use the tree info file to locate available
ISO images for installing fullyvirt guests, so I'd like to get the ISO entries
re-added to rawhide's .treeinfo.

Preferrably with the entry key named 'boot.iso', even if the resulting value is
still called 'netinst.iso'

Version-Release number of selected component (if applicable):
Rawhide tree on March 10, 2008

How reproducible:
Always

Steps to Reproduce:
1. Open .treeinfo file
2. Look at [images-i386]  section
3.
  
Actual results:
No ISO images listed

Expected results:
Entry for 'boot.iso'

Additional info:
Unclear whether 'pungi' is the best place to enter bugs about the composed trees
or not - feel free to move to different product/component if there's a better one

Comment 1 Jesse Keating 2008-03-10 16:31:24 UTC
Turns out, this is buildinstall.

Comment 2 Jesse Keating 2008-03-10 16:46:40 UTC
I'm getting very lost reading the scripts trying to find when netinst.iso is
actually written.  Leaving it up to Jeremy.

Comment 3 Jeremy Katz 2008-03-10 17:42:37 UTC
Added back, although the format of the file makes it so you could conceivably
get the iso listed even if it wasn't built.  

Comment 4 Bug Zapper 2008-05-14 05:54:23 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.