Bug 436840 - sometimes automated check occurs when network not available?
Summary: sometimes automated check occurs when network not available?
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-10 18:59 UTC by Jeremy Katz
Modified: 2008-03-26 13:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:59:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
What i've just merged into git (4.58 KB, patch)
2008-03-16 23:53 UTC, Richard Hughes
no flags Details | Diff

Description Jeremy Katz 2008-03-10 18:59:13 UTC
I've seen this now twice, but can't put a better set of circumstances around it.
 But I've got PK set to check for updates hourly and when I suspend, I've
resumed and had the notification bubble about a problem getting the info for a
network repo.

Comment 1 Richard Hughes 2008-03-16 23:53:31 UTC
Created attachment 298226 [details]
What i've just merged into git

When you resume, PK forces a check to make sure the caches are valid. It could
be we are doing that when the network is still coming up.

The attatched patch should fix things, which I'll merge into git after I've
tested it out and make check completes. Thanks.

Comment 2 Richard Hughes 2008-03-16 23:55:42 UTC
Committed to git.

Comment 3 Robin Norwood 2008-03-19 21:34:47 UTC
This seems to be fixed for me in git, and should be fixed in 0.1.10 or later.


Note You need to log in before you can comment on or make changes to this bug.