Bug 436842 - Gnome Controllpanel Background crashes
Gnome Controllpanel Background crashes
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-backgrounds (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 15:02 EDT by Silvio Schneider
Modified: 2013-03-05 22:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 12:47:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Silvio Schneider 2008-03-10 15:02:38 EDT
Description of problem:
Gnome Controllpanel Background crashes when opening it

Version-Release number of selected component (if applicable):
2.20

How reproducible:
I just dumped Fedora 7 to install Fedora 8. I am running it on a shuttleX, a
quite small PC. Fedora 7 was running fine on it. Fedora 8, unfortunatly has a
problem with gnome. This PC does only have 192MB RAM (default for this machine,
Don't worry CPU is 2 GHZ, works fine for a movieplayer). When I start up gnome
it allready says that gnome power management is not set up right. I don't have
any backgroundpic at all. Also the nice Icons in the top menu are missing. Well
it still works. Only the background changer doesn't open. This controllpanel app
crashes at start.

I have done yum update, so that's not the case.

Steps to Reproduce:
1. Open Gnome Controllpanel Background
2. crashes at start, unfortunalty autobug report fails then
3.
  
Actual results:
crashes

Expected results:
Should open the background changer

Additional info:
I can go back and install fedora 7 again, or I can make the world a better
place. I would like to go for the second. Please tell me how to continue. What
is needed? Dumps, screenshots, logs?
Comment 1 Silvio Schneider 2008-03-14 12:47:17 EDT
Hi all,

I found a workaround. Most important on this issue is that its a Shuttle XPC PC
with AMD CPU and VIA Chipset. It has originally 256 MB RAM. The Shared Memorie
for the graphic card takes 64 MB Away. Leaving somehow 192 MB RAM for the CPU.
This is not enough for the graphical installer of Fedora 8.
This is the workaround: I anstalled 1 GB RAM addional. I reinstalled Fedora 8
with the graphical installer. Controllpanel Background works now. Additionaly
the system runs much smother, because it doesn't have to swap anymore.
Conclusion: This bug can be closed for now, unless someone want to fix the low
ram issue. It would be whise to reconsider the install routine. The installer
could be more strict, for example: If the System doesn't have 256MB RAM at
least, then gnome isn't installed at all. Installing something that deosn't work
correctly doesn't make sense anyway. The installer is not the issue of this
support. I will make some tests with the new installation. In case there is
still something I will open a new report. 

Note You need to log in before you can comment on or make changes to this bug.