Bug 436855 - loader rejects all HTTP/FTP trees when run from netinst.iso
loader rejects all HTTP/FTP trees when run from netinst.iso
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-03-10 15:41 EDT by Will Woods
Modified: 2008-03-12 11:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 11:08:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2008-03-10 15:41:18 EDT
I'm running netinst.iso from today's rawhide, and giving it a (known-good) URL
to install from on the commandline (method=http://....)

It rejects it and requests the URL again. The log says:
[$URL represents the proper URL, which I don't feel like typing out]

INFO  : URL_STAGE_MAIN - url is $URL
INFO  : trying to mount CD device /dev/sr0 on /mnt/source
INFO  : mntloop /dev/loop0 on /mnt/runtime as /mnt/source/images/stage2.img fs is 16
INFO  : transferring $URL/.discinfo to a fd
ERROR : bad HTTP response code:
INFO  : umounting loopback /mnt/runtime /dev/loop0
ERROR : LOOP_CLR_FD failed for /mnt/runtime /dev/loop0 (Device or resource busy)

I hit OK (since the URL is, in fact, correct) and it gives me the

"Retrieving                 "

message (which should probably say "Retrieving stage2.img" but that's a separate
bug). After it finishes downloading stage2.img it gives:

Error: Unable to retrieve the install image.

The log indicates that it's downloaded stage2.img but it can't LOOP_SET_FD
/tmp/stage2.img ('cuz loop0 is still in use from above).

Hitting OK takes me back to the "URL Setup" screen, and thus I'm stuck in a loop.
Comment 1 Chris Lumens 2008-03-11 10:56:28 EDT
This should be fixed in today's Rawhide, though the loopback stuff is a
different problem and is not fixed quite yet.
Comment 2 Jesse Keating 2008-03-12 11:08:34 EDT
Confirmed fixed.

Note You need to log in before you can comment on or make changes to this bug.