Bug 436861 - x86_64: 2.6.24.3-12.fc8: I/O-port access SIGSEGV
Summary: x86_64: 2.6.24.3-12.fc8: I/O-port access SIGSEGV
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-03-10 20:00 UTC by Jan Kratochvil
Modified: 2008-03-13 07:34 UTC (History)
0 users

Fixed In Version: kernel-2.6.24.3-22.fc8.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 07:34:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase (463 bytes, text/plain)
2008-03-10 20:00 UTC, Jan Kratochvil
no flags Details
The real testcase. (275 bytes, text/plain)
2008-03-10 20:04 UTC, Jan Kratochvil
no flags Details

Description Jan Kratochvil 2008-03-10 20:00:08 UTC
Description of problem:
irda-utils findchip segfaults because `outb' segfaults despite previous
successful ioperm(2).

Version-Release number of selected component (if applicable):
kernel-2.6.24.3-12.fc8.x86_64 (F8, broken)
but it work on: kernel-2.6.25-0.101.rc4.git3.fc9.x86_64 (Rawhide)

How reproducible:
Always.

Steps to Reproduce:
1. gcc -o outport outport.c -Wall -ggdb2

Actual results:
Segmentation fault

Expected results:
PASS

Additional info:
strace ./outport
...
ioperm(0x3f0, 0x1, 0x1)                 = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

# gdb ./outport
...
(gdb) r
Starting program: /tmp/outport 

Program received signal SIGSEGV, Segmentation fault.
0x000000000040059b in main () at outport.c:14
14        __asm__ __volatile__ ("outb %b0,%w1": :"a" (value), "Nd" (port));
(gdb) x/i $rip
0x40059b <main+83>:     out    %al,(%dx)
(gdb) p/x $rdx
$1 = 0x3f0
(gdb)

Comment 1 Jan Kratochvil 2008-03-10 20:00:08 UTC
Created attachment 297504 [details]
Testcase

Comment 2 Jan Kratochvil 2008-03-10 20:04:53 UTC
Created attachment 297505 [details]
The real testcase.

The previous testcase was an unrelated code - a filename typo.

Comment 3 Chuck Ebbert 2008-03-12 22:53:34 UTC
I get PASS on 2.6.24.3-22.fc8.x86_64, with an AMD processor.


Comment 4 Jan Kratochvil 2008-03-13 07:34:06 UTC
(In reply to comment #3)
> I get PASS on 2.6.24.3-22.fc8.x86_64, with an AMD processor.

So it is probably fixed. (this is Intel T7200)



Note You need to log in before you can comment on or make changes to this bug.