Bug 436862 - editorial comments on latency tracer comments
editorial comments on latency tracer comments
Status: CLOSED DUPLICATE of bug 442990
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Realtime_Tuning_Guide (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Steven Rostedt
Jeff Needle
: Documentation
Depends On:
  Show dependency treegraph
Reported: 2008-03-10 16:00 EDT by Lana Brindley
Modified: 2013-10-23 19:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-04-21 20:52:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lana Brindley 2008-03-10 16:00:09 EDT
Description of problem:

There are a number of "editorial ocmments" on the latency tracer howto. Can I
please have someone respond to the issues raised in order to finish this chapter.

Assigned to Clark for distribution :)

Comment 1 Clark Williams 2008-03-11 14:29:22 EDT

the Latency Tracer functionality is being rewritten by Steven Rostedt. I can
think of no one better equipped to provide content.

Reassigning to srostedt.

Comment 2 Lana Brindley 2008-03-11 16:48:37 EDT
Thanks Clark.

Steven, in your re-write, can you please explain the statement below for me too?

"Another way of using the tracing infrastructure is by enabling
/proc/sys/kernel/trace_user_triggered. That will trace only processes that
explicitly used the prctl(0, 1) syscall just before the critical session where
tracing is desired and prctl(0, 0) after it."

I don't really understand what effect the prctl() calls have on both the process
and the tracer.

Comment 3 Lana Brindley 2008-03-26 23:06:11 EDT
Steven, This is a friendly reminder :) LKB
Comment 4 Lana Brindley 2008-04-21 20:52:23 EDT

*** This bug has been marked as a duplicate of 442990 ***

Note You need to log in before you can comment on or make changes to this bug.