Bug 436899 - [DMAR] kernel panic with Intel(R) Core(TM)2 Duo CPU E6750
[DMAR] kernel panic with Intel(R) Core(TM)2 Duo CPU E6750
Status: CLOSED DUPLICATE of bug 445553
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 20:17 EDT by Ian Mortimer
Modified: 2009-12-31 05:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-11 21:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Mortimer 2008-03-10 20:17:03 EDT
Description of problem:
The latest Fedora kernel 2.6.24.3-12.fc8 fails to boot with:

Kernel panic - not syncing: DMAR hardware is malfunctioning

This is on a HP Compaq desktop with CPU:

Intel(R) Core(TM)2 Duo CPU     E6750  @ 2.66GHz


Version-Release number of selected component (if applicable):
kernel-2.6.24.3-12.fc8


How reproducible:
Every time.


Steps to Reproduce:
1. Install latest Fedora 8 Kernel
2. Reboot
3.
  
Actual results:
Kernel panic at start of boot.


Expected results:
Boot to proceed as normal.


Additional info:
Boots with kernel 2.6.23.9-85.fc8 and earlier.
Comment 1 Jeroen Beerstra 2008-03-12 05:00:51 EDT
Same problem here, also with a E6750 @ 2.66Ghz (HP Workstation xw4600). Fedora 8
x86_64.
Comment 2 Chuck Ebbert 2008-03-12 19:05:33 EDT
Does booting with the kernel option "intel_iommu=off" help?
Comment 3 Jeroen Beerstra 2008-03-13 06:53:35 EDT
Yes, the system boots with this setting, thank you!
Comment 4 Chuck Ebbert 2008-03-14 16:40:55 EDT
The reporter of bug 436816 says a BIOS update fixed his problem.
Comment 5 Jeroen Beerstra 2008-03-18 03:59:27 EDT
Upgraded to bios v1.06, but no luck.
Comment 6 Ian Mortimer 2008-03-18 18:06:12 EDT
On a HP Compaq dc7800:

panics with latest kernel 2.6.24.3-34.fc8
boots with intel_iommu=off
bios is latest.
Comment 7 henry.wayne 2008-04-02 16:53:08 EDT
Also occurs on HP dc7800 with Intel Quad Core Q6600 on any kernel beyond
2.6.23.15-137.x86_64.fc8

Need IOMMU for v.large memory operations within large simulations.

No BIOS upgrade available from HP.  Where next??
Comment 8 Chuck Ebbert 2008-04-02 18:35:50 EDT
(In reply to comment #7)
> Also occurs on HP dc7800 with Intel Quad Core Q6600 on any kernel beyond
> 2.6.23.15-137.x86_64.fc8
> 
> Need IOMMU for v.large memory operations within large simulations.
> 
> No BIOS upgrade available from HP.  Where next??
> 

iommu=soft
?
Comment 9 henry.wayne 2008-04-04 05:26:41 EDT
iommu=soft works.  no significant degradation in memory ops to 8Gb.  anticipate
no issue scaling upwards from there.

thanks for the setting.  presume i can read up on all configs for iommu somewhere?
Comment 10 Dave Jones 2008-04-04 13:18:21 EDT
ideally, this box would boot without needing to specify options at all.
I'll send mail to some Intel folks and ask them to take a look at this.
Comment 11 Chuck Ebbert 2008-05-14 22:17:45 EDT
(In reply to comment #9)
> iommu=soft works.  no significant degradation in memory ops to 8Gb.  anticipate
> no issue scaling upwards from there.
> 
> thanks for the setting.  presume i can read up on all configs for iommu somewhere?

In the kernel-doc package, files kernel-parameters.txt and x86_64/boot-options.txt

(I still don't understand why it panics the box if the hardware isn't working.
It should just fail the driver init and continue...)
Comment 12 Chuck Ebbert 2008-06-11 21:25:48 EDT

*** This bug has been marked as a duplicate of 445553 ***
Comment 13 Hantsy Bai 2009-12-31 05:53:32 EST
I encounter the same problem on my new netebook- hp compaq cq40 609tx...
I used the intel_iommu=off to start up installer...
It avoid the kernelpanic error, but stop on hardware detection at starting up installer...

Note You need to log in before you can comment on or make changes to this bug.