Bug 436908 - /etc/sgml/catalog includes a wrong line
/etc/sgml/catalog includes a wrong line
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openjade (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-10 23:04 EDT by Devrim GUNDUZ
Modified: 2008-03-11 05:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 05:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/catalog/sgml (394 bytes, patch)
2008-03-10 23:04 EDT, Devrim GUNDUZ
no flags Details | Diff

  None (edit)
Description Devrim GUNDUZ 2008-03-10 23:04:08 EDT
Description of problem:
The first line of /etc/sgml/catalog is:
CATALOG "/etc/sgml/openjade-1.3.2-30.fc8.soc"

Since that file does not exist, I cannot build packages which uses that catalog
file during building.

Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:

1. Download and rebuild:
http://developer.postgresql.org/~devrim/rpms/other/slony1/postgresql-slony1-1.2.13-1.f8.src.rpm
2. Package will not build with these errors:

openjade:/etc/sgml/catalog:1:8:E: cannot open
"/etc/sgml/openjade-1.3.2-30.fc8.soc" (No such file or directory)

The fix is attached.

Regards, Devrim
Comment 1 Devrim GUNDUZ 2008-03-10 23:04:08 EDT
Created attachment 297557 [details]
Patch for /etc/catalog/sgml
Comment 2 Ondrej Vasik 2008-03-11 03:30:32 EDT
Thanks for report, but this is quiet strange thing. 
Registration to the catalog is done by spec file
( by following sequence
%post
/sbin/ldconfig
/usr/bin/install-catalog --add /etc/sgml/%{name}-%{version}-%{release}.soc \
    %{_datadir}/sgml/%{name}-%{version}/catalog >/dev/null 2>/dev/null || :
 
%preun
/usr/bin/install-catalog --remove /etc/sgml/%{name}-%{version}-%{release}.soc \
    %{_datadir}/sgml/%{name}-%{version}/catalog >/dev/null 2>/dev/null || :
)
So something went wrong during your upgrade to fedora 9 openjade package. Could
you please provide following informations?
1)rpm -q openjade 
2)rpm -V openjade
3)rpm -q sgml-common
4)rpm -V sgml-common
5)rpm -qf /usr/bin/install-catalog

It looks like that during your upgrade there was no/modified sgml-common package
(which provides /usr/bin/install-catalog) and registration of new package was
not correct - or something else went wrong. I tried the upgrade on my machine
and it works without troubles.
Comment 3 Ondrej Vasik 2008-03-11 03:34:39 EDT
Btw. your patch is hardcoded for that one specific version and release, so in
any case I could not use it - /etc/sgml/catalog file is not owned by openjade
package. On my machine the upgrade works , so I would say this is most probably
something system specific or very rare. But it should be clarified before fixing
it or closing notabug.
Comment 4 Devrim GUNDUZ 2008-03-11 03:44:40 EDT
Platform details: Fedora-8 installation, and the upgraded to rawhide a ~2 months
ago.

Patch info: Yes, it was not an actual patch, I just wanted to show how I fixed
my problem.

Here is the info you asked:
=============================================================
# rpm -q openjade
openjade-1.3.2-31.fc9.i386
# rpm -V openjade
prelink: /usr/bin/openjade: at least one of file's dependencies has changed
since prelinking
S.?.....    /usr/bin/openjade
prelink: /usr/lib/libogrove.so.0.0.1: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/lib/libogrove.so.0.0.1
prelink: /usr/lib/libospgrove.so.0.0.1: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/lib/libospgrove.so.0.0.1
prelink: /usr/lib/libostyle.so.0.0.1: at least one of file's dependencies has
changed since prelinking
S.?.....    /usr/lib/libostyle.so.0.0.1
# rpm -q sgml-common
sgml-common-0.6.3-23.fc9.noarch
# rpm -V sgml-common
# rpm -qf /usr/bin/install-catalog 
sgml-common-0.6.3-23.fc9.noarch
=============================================================

Please let me know if I can provide more data.

Regards, Devrim
Comment 5 Ondrej Vasik 2008-03-11 05:09:10 EDT
Really strange. I have exactly same configuration (i386 architecture, same
package versions) on my machine and updates work correctly. The only difference
is that I have rpm -V openjade silent ... Tried once more time to go back to F8
packages and then update to RAWHIDE - worked again without troubles. Don't know
what could be wrong - when updating Fedora it is always some kind of black magic
(especially when updating to rawhide which could be broken almost any time),
closing that bug WORKSFORME - as I tried the common update process on the same
architecture as you have and with the packages you had/have. I'm quiet sure that
the problem is in different area than openjade package - but I'm not able to say
where and I doubt we can find it easily - it seems to be something caused by the
update process.

Note You need to log in before you can comment on or make changes to this bug.