Bug 436932 - "mkisofs -no-emul-boot /blah" causes a segmentation fault
"mkisofs -no-emul-boot /blah" causes a segmentation fault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cdrtools (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Harald Hoyer
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 04:42 EDT by Andrew Ryan
Modified: 2010-10-22 19:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
check that cbe->boot_image isn't NULL (586 bytes, patch)
2008-03-11 04:42 EDT, David Robinson
no flags Details | Diff

  None (edit)
Description David Robinson 2008-03-11 04:42:08 EDT
Description of problem:
When mkisofs's -no-emul-boot option is used but an image isn't specified (-b
image) mkisofs will segfault.

Version-Release number of selected component (if applicable):
mkisofs-2.01.1-5

How reproducible:
100%

Steps to Reproduce:
1. mkisofs -no-emul-boot /blah
  
Actual results:
# mkisofs -no-emul-boot /blah
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
Segmentation fault

Expected results:
no segfault

Additional info:
Patch to correct the problem is attached.
Comment 1 David Robinson 2008-03-11 04:42:09 EDT
Created attachment 297581 [details]
check that cbe->boot_image isn't NULL
Comment 9 Jörg Schilling 2009-02-10 11:15:23 EST
You are using bad/outdated software.

This bug has been fixed in mkisofs in February 2005.

Here is recent original software:

ftp://ftp.berlios.de/pub/cdrecord/alpha/
Comment 13 errata-xmlrpc 2009-05-18 16:29:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1007.html

Note You need to log in before you can comment on or make changes to this bug.