Bug 436942 - Kernel panic upon attempt to remount the root fs on boot
Kernel panic upon attempt to remount the root fs on boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
8
i686 Linux
low Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 06:08 EDT by Rene Sedmik
Modified: 2008-03-12 16:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 16:48:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rene Sedmik 2008-03-11 06:08:21 EDT
Description of problem:

The system hangs upon restarting after a fresh fc8 installation.

I installed from DVD (five times, three different dvd isos from three different
mirrors, all reported errors during the media check, but I consider this not to
be a problem since others had the same checking problem with working boot media.
There have also been reports on this topic on various newsgroups on the net).
Installations always finish without any problems on my machine. 
After the kernel is started by grub and attepts to remount the root fs it
doesn't find the mount point and panics.
Last 4 lines on the screen:
 md: ... autorun DONE
 VFS: Cannot open root device "VolGroup00/LogVol00" or unknown block (0,0)
 Please append a correct "root=" boot option; here are the available options:
 Kernel panic - not syncing: VFS: unable to mount root fs on unknown block (0,0)

This error appears in several variations in numerous boards and newsgroups but
there seems to be no real solution.
+ I tried to install using the default layout with/without LVM -> no success
+ I assured that /dev/VolGroup00/LogVol00 or alternatively /dev/sda3 are my root
partitions
+ The rescue discs (both, fc8 and fc9 prerelease) can mount the root fs
successfully rw
+ The system worked well without any problems in fc5, fc6, and fc7
+ I use grub for dualboot with fedora and windows. The latter one can be booted
without problems
+ No initrd has been created by anaconda. I tried to make it manually after
booting with the rescue disk:
  mkinitrd -f -v --fstab=/etc/fstab /boot/initrd2.6.23.1-42.img 2.6.23.1-42.fc8
  but it does not create anything but states:
  No modules available for kernel 2.6.23.1-42.fc8
+ my grub.conf contains the following entry:
  title Fedora 2.6.23.1-42.fc8
  root (hd0,1)
  kernel lvmlinuz-2.6.23.1-42.fc8 ro root=/dev/VolGroup00/LogVol00
+ the fstab contains the corresponding line:
  /dev/VolGroup00/LogVol00/ ext3 defaults 1 1
+ The computer is an ASUS M6800V Laptop, Intel M 760,1GB Ram
  HDCtrl: Intel 82801FB/FBM Ultra ATA
  HD: Fujitsu-Siemens MHV2100AH, 100GB
  NIC:Marvell Yukon Gigabit Ethernet 10/100/1000 88E8001

+ By the way, as has been reported in this board, network install does not work
at all for fc8 and fc9. All anaconda versions (fc8/fc9) (I tried on rescue or
install media) recognized my NIC and sent a DHCP request to my rooter (log) but
were not able to process the ip address packet they got back from the rooter.
Ping (upon starting with rescue) on the loopback gives regular results, but no
external link can be established.

Please help me with this boot problem since I need to work on this machine.

Version-Release number of selected component (if applicable):

Kernel: 2.6.23.1-42.fc8

How reproducible:
every boot

Steps to Reproduce:
1. install fc8 (arbitrary source) on ASUS M6800V
2. reboot with GRUB
3. kernel panic after attempting to remount root fs
  
Actual results:
...
Kernel panic - not syncing: VFS: unable to mount root fs on unknown block (0,0)

Expected results:

regular boot

Additional info:

pls. see above
Comment 1 Rene Sedmik 2008-03-12 16:48:05 EDT
Problem solved.

Today I made a download a DVD directly from fedoraproject.org and the media
check was OK. Further Installation succeeded as before without problems, and the
installer created an initrd.img this time. Reboot works.

Still the NIC was not recognized by Anaconda, so no network install would have
been possible but, finally, the DVD install succeeded. After reboot networking
works as usual. 

Last Question: Why does Anaconda not recognize and signal errors during
initialization or setup?

Note You need to log in before you can comment on or make changes to this bug.