Bug 436955 - suck needs to be rebuild against perl 5.10
suck needs to be rebuild against perl 5.10
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: suck (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 07:56 EDT by Jonathan Kamens
Modified: 2008-03-11 17:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 17:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-03-11 07:56:07 EDT
Suck needs to be rebuilt against perl 5.10 because it's looking for libperl.so
in the wrong place.

Actually, this brings to light an interesting RPM dependency issue which I'm not
sure whether should be a bug of its own.  Suck's RPM claims to depend on
libperl.so; perl-libs claims to provide libperl.so; but the directory in which
suck is expecting it is different from the directory in which perl-libs provides
it.  Because of this, yum will happily allow perl to be updated even though
it'll break suck.  I'm not sure there's a good solution to this.  What do you think?
Comment 1 Jochen Schmitt 2008-03-11 17:18:43 EDT
Suck is rebuilt for perl 5.10 in suck-4.3.2-21.fc9

Note You need to log in before you can comment on or make changes to this bug.