Bug 436962 - Epiphany Webkit package would be great
Epiphany Webkit package would be great
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-11 08:37 EDT by Martin Jürgens
Modified: 2008-03-31 16:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-31 16:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2008-03-11 08:37:47 EDT
Description of problem:
With Webkit now supporting Webkit (using --with-engine=webkit in configure), it
would be great if an epiphany-webkit package could be provided in Rawhide.
Comment 1 Christopher Aillon 2008-03-31 16:39:03 EDT
Well, WebKit support is still experimental.  There's still quite a bit of work
that needs to go into it before it's usable for users in general.  See
http://live.gnome.org/Epiphany/WebKit/TODO for some of them.

That being said, I think we should let upstream dictate what happens here.  They
should either:
 * allow building both simultaneously with UI to switch backends
   (see also Netscape 9), or
 * remove support for one of the backends.

Requiring two different packages to account for mutually exclusive options to
configure is silly.  WONTFIX for now since there isn't a resolution that really
suits this better...

Note You need to log in before you can comment on or make changes to this bug.