Bug 436980 - Miro doesn't do anything useful
Miro doesn't do anything useful
Status: CLOSED DUPLICATE of bug 393521
Product: Fedora
Classification: Fedora
Component: Miro (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 10:29 EDT by Dennis Jacobfeuerborn
Modified: 2008-03-11 10:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 10:50:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Jacobfeuerborn 2008-03-11 10:29:26 EDT
Miro doesn't seem to be a useful application in its current state. After
starting Miro it just shows a mostly empty window with some controls at the
bottom. Selecting "YouTube" in the drop-down, entering something to search for
and clicking go does nothing. Opening a locally stored video from the menu does
nothing. I'm not sure how to get it to do what is advertised on its homepage.

Here is what I get when I start Miro from the shell:

[dennis@nexus ~]$ miro
/usr/lib/xulrunner-1.9pre
INFO     Starting up Miro
INFO     Version:    1.1.2
INFO     Revision:  
https://svn.participatoryculture.org/svn/dtv/tags/Miro-1.1.2/tv/resources - 6194
INFO     Builder:    mockbuild@xenbuilder4.fedora.phx.redhat.com
INFO     Build Time: 1205241379.45
INFO     Loading preferences...
INFO     Starting event loop thread
INFO     Restoring database...
INFO     Connecting to /home/dennis/.miro/sqlitedb
TIMING   Database load slow: 0.269
INFO     Spawning auto downloader...
INFO     Spawning idle notifier
INFO     idle notifier running
INFO     Displaying main frame...
WARNING  Menu item action "RenameVideo" not implemented
WARNING  Menu item action "FastForward" not implemented
WARNING  Menu item action "Rewind" not implemented
WARNING  Menu item action "UpVolume" not implemented
WARNING  Menu item action "DownVolume" not implemented
INFO     Creating video display...
INFO     *** Launching Downloader Daemon ****
INFO     loaded renderer 'xinerenderer'
TIMING   gtkAsyncMethod: <function initRenderers at 0x94f15dc> took too long: 1.128
TIMING   gtkSyncMethod: <function getDisplay at 0x954b924> took too long: 1.353
INFO     First URL is https://www.miroguide.com/
WARNING! setupDragAndDrop failed
TIMING   Icon clear: 0.054
INFO     Starting movie data updates
INFO     Finished startup sequence
TIMING   idle (finalizing startup) too slow (1.607 secs)
WARNING! setupDragAndDrop failed
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme: 
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme: 
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme: 
INFO     *** Daemon ready ***
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme: 
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme: 
WARNING: u'None' has no scheme
WARNING: Assuming port 80 for scheme: 
INFO     Checking for updates...
INFO     Up to date.
INFO     Shutting down Downloader...
INFO     Shutting down downloaders...
INFO     Shutdown complete
INFO     Closing Database...
INFO     Shutting down event loop
INFO     Shutting down frontend
INFO     Saving preferences...
INFO     Shutting down icon cache updates
INFO     Shutting down movie data updates
INFO     Shutting down IdleNotifier
INFO     Done shutting down.
INFO     Remaining threads are:
INFO     <_MainThread(MainThread, started)>
Comment 1 Alex Lancaster 2008-03-11 10:50:07 EDT
Yep, known problem (bug #393521).  The issue is that it hasn't been properly
ported to work with xulrunner upstream (I've filed a upstream bug and there was
been no response).

*** This bug has been marked as a duplicate of 393521 ***

Note You need to log in before you can comment on or make changes to this bug.