Bug 436981 - xfig not selecting fonts correctly
xfig not selecting fonts correctly
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xfig (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Stanislav Ochotnicky
desktop-bugs@redhat.com
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 10:32 EDT by Troy Dawson
Modified: 2012-03-06 05:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 05:05:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproduction of the issue (36.88 KB, image/png)
2008-07-18 16:50 EDT, Matěj Cepl
no flags Details
a patch, backported from 3.2.5 (2.03 KB, text/plain)
2009-01-15 10:44 EST, Stepan Kasal
no flags Details

  None (edit)
Description Troy Dawson 2008-03-11 10:32:57 EDT
Description of problem:


Version-Release number of selected component (if applicable):
xfig-3.2.4-21.2.el5 both i386 and x86_64

How reproducible:
Every time

Steps to Reproduce:
1.Start xfig (/usr/bin/xfig)
2.Click on the "T" icon, for inputing text
3.Click on the "Text Font" which brings up the box for selecting a font
4.Click on the Zapf Dingbat font (It is the font that is all symbols).  Note:
There are several other fonts with this problem, this is just the easiest to see
5.Click anywhere on the page and start to input your text
  
Actual results:
A dialog box pops up saying "Can't find -*-itc zapf
dingbats-*-*-*--12-*-*-*-*-*-*-*, using 6x13"
The text you enter is then a plain block text.

Expected results:
That the text you type is is the font you selected

Additional info:
This is on both i386 and x86_64
I have tried installing all the fonts (yum install "*font*"), and even rebooting.
Comment 1 Troy Dawson 2008-03-11 10:34:09 EDT
A co-worker says that they were able to fix the problem by upgrading the
following packages from Fedora 7.
xfig-3.2.5-5.fc7.x86_64.rpm
xfig-common-3.2.5-5.fc7.x86_64.rpm
transfig-3.2.5-1.fc7.x86_64.rpm
xdg-utils-1.0.2-4.fc7.noarch.rpm

I have not done that, hoping that this can be fixed with RHEL only packages.
Comment 2 Steve 2008-06-03 20:33:07 EDT
I can confirm that this bug is also present in the xfig that comes with Fedora
9.  I've had to install the FC6 version, which doesn't have this problem.

The problem is mentioned in this thread as well as possible fix:

http://www.fedoraforum.org/forum/showthread.php?t=162677&highlight=xfig
Comment 4 Matěj Cepl 2008-07-18 16:50:10 EDT
Created attachment 312170 [details]
Reproduction of the issue

Can reproduce with the latest upgrades to RHEL 5.2
Comment 5 Matěj Cepl 2008-07-18 16:50:42 EDT
s/5.2/5.1/
Comment 6 Adam Jackson 2008-07-18 18:35:27 EDT
Does the workaround suggested in the forum thread work for you?
Comment 7 Stepan Kasal 2009-01-15 10:44:49 EST
Created attachment 329102 [details]
a patch, backported from 3.2.5

Reproduced with RHEL 5.3.
Attached please find a patch.
Comment 8 RHEL Product and Program Management 2009-03-26 12:48:38 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 RHEL Product and Program Management 2011-01-11 15:07:20 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-01-12 10:23:57 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 Bjorge Solli 2011-02-14 07:37:49 EST
I also see this in Fedora 14 64-bit.
Comment 12 Steve 2011-02-15 01:49:00 EST
Interestingly, I'm not seeing it in my installation of Fedora 14 64-bit.
Comment 13 Stanislav Ochotnicky 2011-03-01 12:08:22 EST
(In reply to comment #11)
> I also see this in Fedora 14 64-bit.

If you can reproduce on Fedora please file a separate bug (However same as Steve I am unable to reproduce).
Comment 14 Bjorge Solli 2011-03-31 03:24:47 EDT
Could anyone explain to me what is the actual problem?
Comment 15 Bjorge Solli 2011-03-31 03:50:56 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=692382 is filed. It seems my problem is a bit different as I get the errors on all fonts.
Comment 16 Stanislav Ochotnicky 2011-03-31 04:03:32 EDT
(In reply to comment #14)
> Could anyone explain to me what is the actual problem?

Problem is being unable to use Zapf Dingbat, symbol and few other fonts for text input in xfig. Just look at comment 1 for description
Comment 17 Bjorge Solli 2011-03-31 04:58:16 EDT
That is the symptom. I am trying to understand the underlying problem that causes the user to be unable to use those fonts to find out why this happens to me on Fedora 14 and not for you.
Comment 18 Troy Dawson 2011-03-31 10:49:25 EDT
I have tested this on RHEL6 both 32 bit and 64 bit.  It works correctly now.
Thank You
Comment 19 RHEL Product and Program Management 2011-05-31 09:15:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 20 Stanislav Ochotnicky 2012-03-06 05:05:48 EST
OK. Since the original reported moved on to fixed version in RHEL6 and the problem is rather minor I am closing this. If you still feel this should be fixed in current release, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.