Bug 437006 - perl-devel sucked into desktop install/live images
perl-devel sucked into desktop install/live images
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-11 12:37 EDT by Jeremy Katz
Modified: 2008-03-17 07:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 07:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to move xsubpp to perl-devel (746 bytes, text/x-patch)
2008-03-12 08:09 EDT, Ralf Corsepius
no flags Details

  None (edit)
Description Jeremy Katz 2008-03-11 12:37:44 EDT
perl-devel is getting pulled into the defaults again, it looks like due to
perl-ExtUtils-ParseXS.  -devel packages should not be included in a default
desktop install
Comment 1 Marcela Mašláňová 2008-03-12 05:42:57 EDT
Any thoughts? Is it devel package here indispensable?
Comment 2 Ralf Corsepius 2008-03-12 08:07:30 EDT
One cause seems to be the main "perl" package to requires
perl(ExtUtils::ParseXS), because /usr/bin/xsubpp requires it.

=> installing "perl" pulls in "perl-devel"

One approach to circumvent this issue would be to move /usr/bin/xsubpp
into a different package.

IMO, a feasible approach would be to move
/usr/bin/xsubpp and /usr/share/man1/xsubpp*
to "perl-devel"
Comment 3 Ralf Corsepius 2008-03-12 08:09:42 EDT
Created attachment 297752 [details]
patch to move xsubpp to perl-devel
Comment 4 Marcela Mašláňová 2008-03-12 08:24:20 EDT
Move it to perl-devel isn't problem, but shouldn't we also add into many
packages BR: perl-devel?
Comment 5 Ralf Corsepius 2008-03-12 09:00:39 EDT
Could you elaborate?

Do you mean this mover would break packages because they currently only BR: or
R: "perl" and would have to be changed to R:/BR: perl-devel?

I am not sure about this.

Comment 6 Jeremy Katz 2008-03-12 09:58:09 EDT
From the man page, it looks like the main user is ExtUtils::MakeMaker so as long
as perl-ExtUtils-MakeMaker requires /usr/bin/xsubpp (or the package containing
it), I don't think it should have a significant impact on buildreqs.
Comment 7 Marcela Mašláňová 2008-03-12 11:25:22 EDT
Ok, it will be in rawhide soon. Please test it.
Comment 8 Ralf Corsepius 2008-03-14 05:40:57 EDT
Ping? 

Marcela, *-15 still doesn't seem to have made it to rawhide.
Comment 9 Marcela Mašláňová 2008-03-14 05:51:41 EDT
That's because new builds must be announced to rel-eng. I'll ask them.

Note You need to log in before you can comment on or make changes to this bug.