Bug 437016 - updated kernel flips network drivers between cards
updated kernel flips network drivers between cards
Status: CLOSED DUPLICATE of bug 436456
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-11 13:33 EDT by Alexander Tetervak
Modified: 2008-03-12 15:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-12 15:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alexander Tetervak 2008-03-11 13:33:43 EDT
Description of problem:

After upgrade of kernel to the network connection
became unstable.

I have two network cards on my mother board of my triple-boot system, one
network card is unplugged.

FC8 kernel, FC5 kernel 2.6.20-1.23.16 and Windows XP recognize the
plugged network card as "Marvell 88E8001, MAC 00:11:d8:82:a1:9a" and the
unplugged one as "nVidia Corporation CK804, MAC 00:11:d8:82:a6:36" by Fedora and
"NVIDIA nForce Networking Controlller" by Windows XP.

After upgrading FC8 kernel to, the plugged card became "nVidia
Corporation CK804, MAC 00:11:d8:82:a1:9a" Please note, the name had changed but
MAC address remains the same. 
Since the name changed (MAC is the same) and connection became unstable, I
suspect that the kernel has associated drivers with wrong cards.
The unplugged card has also become the opposite with the old hardware address.  

Version-Release number of selected component (if applicable):

How reproducible:
Comment 1 Alexander Tetervak 2008-03-11 19:24:06 EDT
I made mistake in description the broken kernel is (the latest on
automatic update now) and  the one before upgrade works fine. 

I must be 

Version-Release number of selected component (if applicable):

not the above,  I am sorry about the mistake.
Comment 2 Alexander Tetervak 2008-03-12 11:08:34 EDT
I found walk around that works for me now.

1. plugged both network cards.
2. unchecked "Bind to MAC address" for both cards, since the probed addresses
are wrong with the updated kernel (they switched between).

The network connection seems to be stable now. Although, on each reboot, it
creates me new third device "eth0.bak" in "Network Configuration" which is not
editable (I can only delete it but it appears again after reboot).

There is an obvious new bug in the updated kernel (, because nothing
like this happens with previous kernels (like and
2.6.20-1.2320.fc5) on the same computer.   
Comment 3 Chuck Ebbert 2008-03-12 15:52:42 EDT

*** This bug has been marked as a duplicate of 436456 ***

Note You need to log in before you can comment on or make changes to this bug.