Bug 437030 - [PATCH] Virt-install forces selection of graphics if HVM is used
[PATCH] Virt-install forces selection of graphics if HVM is used
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.3
All Linux
low Severity low
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 15:00 EDT by Adam Stokes
Modified: 2010-10-22 19:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 17:54:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
define default vnc values if hvm is used in virt-install (488 bytes, patch)
2008-03-11 15:00 EDT, Adam Stokes
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-03-11 15:00:39 EDT
Description of problem:
I realize there was a design decision made to support only graphical installs
(via VNC) for Fully-virtualized guests.  That is not the point of this defect.

The defect that needs a fix is that virt-install SHOULD NOT prompt the user for
enabling graphics when the answer to the first question ("install
fully-virtualized guest?") is yes", because you can get yourself into a state
where a new guest is created but it is inaccessible.  Witness:

[root@wheel1 ~]# virt-install
Would you like a fully virtualized guest (yes or no)?  This will allow you to
run unmodified operating systems. yes
What is the name of your virtual machine? fv01
How much RAM should be allocated (in megabytes)? 8192
What would you like to use as the disk (path)? /dev/sdc1
Would you like to enable graphics support? (yes or no) no
What is the virtual CD image, CD device or install location?
http://md2020.nashua/insta ll/ia64/rhel5.1


Starting install...
Retrieving Server...                                            482 kB 00:00
Retrieving boot.iso...    100% |=========================|  26 MB    00:01
Creating domain...                                                 0 B 00:03
Domain installation still in progress.  You can reconnect
to the console to complete the installation process.
[root@wheel1 ~]# xm list
Name                                      ID Mem(MiB) VCPUs State   Time(s)
Domain-0                                   0    98208    32 r-----    520.6
fv01                                       1     8207     1 ------      0.1
[root@wheel1 ~]# xm console fv01
xenconsole: Could not read tty from store: No such file or directory

Version-Release number of selected component (if applicable):
python-virtinst-0.103.x

How reproducible:
100%

Steps to Reproduce:
1. virt-install
2. type 'yes' for hvm install
3. prompts for graphics
  
Actual results:
[root@wheel1 ~]# xm console fv01
xenconsole: Could not read tty from store: No such file or directory

Expected results:
allow console connection via vnc

Additional info:
Comment 1 Adam Stokes 2008-03-11 15:00:40 EDT
Created attachment 297661 [details]
define default vnc values if hvm is used in virt-install
Comment 3 Daniel Berrange 2008-03-11 15:36:22 EDT
Please re-run passing --debug to virt-install and attach the output to this bug.
Also provide /var/log/xen/xend.log  and output of 'xenstore-ls' once the VM is
running.
Comment 4 Adam Stokes 2008-03-12 07:20:09 EDT
Created attachment 297748 [details]
log file
Comment 8 RHEL Product and Program Management 2008-06-02 16:14:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Cole Robinson 2008-06-26 11:20:26 EDT
I laid out the particular nographics issues bz 230841. Its actually a xen bug as
far as I can tell, since it doesn't truly honor a nographics request.

We can use this bug to track the original proposed change, which I'm fine with:
if selecting hvm just default to vnc with no prompt since current other options
are broken.
Comment 10 Cole Robinson 2008-07-15 10:46:45 EDT
Hmm, looks like 230841 is going to be fixed, so if any action should be taken
for this bug it's probably to disable sdl.
Comment 11 Daniel Berrange 2008-07-15 10:53:55 EDT
I don't see why any action needs to be taken - both paravirt and fullyvirt
support install via  text console, VNC and SDL. Sometimes one or more of those
options is not available, due to specifics of the guest OS being installed, or
the way the admin has configure the host, but its not virt-install's job to
define that policy
Comment 12 Cole Robinson 2008-09-14 17:54:59 EDT
Okay, per dan's comment and the fact that nographics should work for hvm guests in 5.3, i'm just going to close this NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.