Bug 437045 - Resolution on external monitor is wrong with new vga cable
Resolution on external monitor is wrong with new vga cable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 17:12 EDT by Valent Turkovic
Modified: 2008-06-04 02:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 16:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1007 bytes, application/octet-stream)
2008-03-11 17:15 EDT, Valent Turkovic
no flags Details
Xorg.0.log (50.10 KB, text/plain)
2008-03-11 17:15 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2008-03-11 17:12:32 EDT
Description of problem:
I connected a new vga cable and now I can't use it because I get some really
strange and wrong resolution on my external 19" monitor from my laptop.

The resolution is 1280x800 but that is the resolution that my internal laptop
screen has. External monitor worked on 1280x1024 with old cable. But that cable
is too thin and I got a new one which is much thicker and gives me much better
video quality.

I have resolution switcher applet started (resapplet) and it offers me these
resolutions:
1360x768
1280x800
1152x864
1280x768
1280x720

but nowhere on that list is 1280x1024

I started system-config-display and choose as monitor LCD 1280x1024 and
testrated X.org but I got message that X can't be stated. I use X without
xorg.conf but once I stated it made one.

I'm attaching this xorg.conf that is not working and a log file of these activities.

Why can't I force my screen to use 1280x1024 resolution?

Cheers,
Valent.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2008-03-11 17:15:20 EDT
Created attachment 297676 [details]
xorg.conf

this is the xorg.conf with which my X don't even start. If I delete xorg.conf
they start but with those strange resolutions I wrote in comment #1
Comment 2 Valent Turkovic 2008-03-11 17:15:45 EDT
Created attachment 297677 [details]
Xorg.0.log
Comment 3 Valent Turkovic 2008-03-11 17:31:59 EDT
http://www.p4c.philips.com/files/1/190v6fb_27/190v6fb_27_pss_aen.pdf

PDF with technical specs says that this monitor has:
Maximum Resolution: 1280 x 1024 @ 75 Hz
Recommended Resolution: 1280 x 1024 @ 60 Hz
Video Dot Rate: 140 MHz
Horizontal Scanning Frequency: 30 - 83 kHz
Vertical Scanning Frequency: 56 - 76 Hz
Comment 4 Valent Turkovic 2008-03-11 17:52:41 EDT
I hard coded these specs in xorg.conf and now I can choose 1280x1024 with
"resolution switcher applet"

why doesn't X recognize my monitor correctly with different cable?
Comment 5 Adam Jackson 2008-03-12 16:37:23 EDT
It doesn't recognize the monitor because the cable isn't passing the DDC signal
correctly.  We see EDID for the internal panel but not for the external VGA.

Your cable is broken, in other words.
Comment 6 Valent Turkovic 2008-06-04 02:44:48 EDT
Thank you, you are right.

Note You need to log in before you can comment on or make changes to this bug.