Bug 437051 - RFE Rescue mode should be smarter about asking for passwords for RAID + Encryption
RFE Rescue mode should be smarter about asking for passwords for RAID + Encry...
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-03-11 17:38 EDT by Bruno Wolff III
Modified: 2008-03-14 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-14 12:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2008-03-11 17:38:54 EDT
Description of problem:
When rescuing a system with encryption over raid, you get prompted for a
password for each partition even though anaconda should be able to tell that the
partition isn't encrypted (by looking for the software raid information to see
if it is readable). While you can get where you want, this is something that is
likely to confuse people and ends up being a lot of busy work. (While I haven't
tested it, presumably entering a key for one or more of the partitions will
result in anaconda trying to use raid over encryption which would break things.)
The test should be pretty reliable as you are unlikely to randomly get raid
setup information just by chance. This should allow you to determining if the
partition is encrypted with raid running on top of that or if the encryption is
on top of the raid.
While I don't expect this to be high priority, it would be nice to eventually
have rescue mode work this way.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install a system with encrypted file systems on top of raid 1 arrays.
2. Boot in rescue mode.
Actual results:
Getting prompted for keys for each partition in addition to each raid array.

Expected results:
Just getting prompted for keys to each raid array.

Additional info:
Comment 1 David Lehman 2008-03-11 18:53:40 EDT
I just ran into this myself today.
Comment 2 David Lehman 2008-03-13 12:52:46 EDT
Should be fixed in anaconda-
Comment 3 Bruno Wolff III 2008-03-14 12:47:41 EDT
I tried it (today's boot.iso) out and it worked great. Thanks!

Note You need to log in before you can comment on or make changes to this bug.