Bug 437055 - On an AMD 32 bit system with 5.1 Dom0 and a 4.6 client, a hugemem kernel cannot ping out of eth0.
On an AMD 32 bit system with 5.1 Dom0 and a 4.6 client, a hugemem kernel cann...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: module-init-tools (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Jon Masters
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-11 18:28 EDT by Barry Donahue
Modified: 2009-03-13 14:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 14:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Barry Donahue 2008-03-11 18:28:13 EDT
Description of problem: Dom0 is 5.1 on AMD 32bit system. All the kernel variants
work except for a z-stream hugemem kernel. The RHEL-5-Server/U1 hugemem kernel
works fine but after I upgrade to a newer z-stream kernel, the network doesn't work.


Version-Release number of selected component (if applicable):
kernel=2.6.9-67.0.1.ELhugemem
xenpv=kmod-xenpv-huemem-0.1-7.el4


How reproducible: Every time


Steps to Reproduce:
1.Install RHEL-5-Server/U1
2.install kmod-xenpv-huemem-0.1-7.el4
3.After verifying that that works install 2.6.9-67.0.1.ELhugemem
  
Actual results:
The modules load OK but the system cannot ping out on eth0.

Expected results:
It should work. It did on every other variant.

Additional info:
Comment 1 Barry Donahue 2008-03-13 17:04:59 EDT
This also happens on Intel processors.
Comment 2 Barry Donahue 2008-04-04 13:47:56 EDT
It looks like this problem is in modversions not the kmod-xen modules. the
scenario that hits the problem is to install the UP kernel and then a z-stream
UP kernel. Install the smp kernel and then the smp z-stream kernel and then the
hugemem and a z-stream hugemem kernel. At the end of all that, the link in
weak-updates will point to the wrong kmod. Here is what it looks like.
ls -l
total 48
lrwxrwxrwx  1 root root 71 Apr  4 15:02 xen-balloon.ko ->
/lib/modules/2.6.9-68.10.ELhugemem/extra/xenpv/0.1-7.el4/xen-balloon.ko
lrwxrwxrwx  1 root root 66 Apr  4 15:02 xenblk.ko ->
/lib/modules/2.6.9-68.10.ELhugemem/extra/xenpv/0.1-7.el4/xenblk.ko
lrwxrwxrwx  1 root root 62 Apr  4 14:43 xennet.ko ->
/lib/modules/2.6.9-68.10.ELsmp/extra/xenpv/0.1-7.el4/xennet.ko
lrwxrwxrwx  1 root root 76 Apr  4 15:02 xen-platform-pci.ko ->
/lib/modules/2.6.9-68.10.ELhugemem/extra/xenpv/0.1-7.el4/xen-platform-pci.ko
lrwxrwxrwx  1 root root 67 Apr  4 15:02 xen-vbd.ko ->
/lib/modules/2.6.9-68.10.ELhugemem/extra/xenpv/0.1-7.el4/xen-vbd.ko
lrwxrwxrwx  1 root root 64 Apr  4 14:43 xen-vnif.ko ->
/lib/modules/2.6.9-68.10.ELsmp/extra/xenpv/0.1-7.el4/xen-vnif.ko

Notice that xen-vnif points to the smp kmod not the hugemem kmod as it should. I
doubt if any one but a test organization will hit this but...

Note You need to log in before you can comment on or make changes to this bug.