Bug 437065 - Firefox starts with two tabs of Fedora Start Page
Firefox starts with two tabs of Fedora Start Page
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
: 441374 (view as bug list)
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-03-11 21:22 EDT by petrosyan
Modified: 2013-01-09 23:35 EST (History)
6 users (show)

See Also:
Fixed In Version: 3.0-0.55.beta5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 17:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot illustrating the problem (57.52 KB, image/png)
2008-03-11 21:22 EDT, petrosyan
no flags Details
screenshot illustrating the problem (102.46 KB, image/png)
2008-03-31 23:19 EDT, Qing LIN
no flags Details
screenshot illustrating the problem, another splash page (82.48 KB, image/png)
2008-04-01 00:42 EDT, Qing LIN
no flags Details

  None (edit)
Description petrosyan 2008-03-11 21:22:43 EDT
Description of problem:
When running Firefox for the very first time it starts with two tabs of "Fedora
Project - Start Page". There is no need for two identical tabs. Attached
screenshot shows the problem.

After closing Firefox and opening it again, it starts with just one "Fedora
Project - Start Page"

Version-Release number of selected component (if applicable):
firefox-3.0-0.38.cvs20080310.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora rawhide.
2. Log in for the first time.
3. Click on the Firefox icon.
  
Actual results:
Two tabs of "Fedora Project - Start Page"

Expected results:
One "Fedora Project - Start Page"
Comment 1 petrosyan 2008-03-11 21:22:43 EDT
Created attachment 297695 [details]
screenshot illustrating the problem
Comment 2 Martin Stransky 2008-03-12 03:34:30 EDT
It's because the product page at mozilla.org is still missing. Will be fixed
after final ff3 release.
Comment 3 Qing LIN 2008-03-31 23:19:46 EDT
Created attachment 299821 [details]
screenshot illustrating the problem
Comment 4 Qing LIN 2008-03-31 23:22:36 EDT
Similar problem with Mozilla Firefox 3.0b5pre, but two different splash pages as
attached.
Comment 5 Qing LIN 2008-04-01 00:42:54 EDT
Created attachment 299830 [details]
screenshot illustrating the problem, another splash page
Comment 6 petrosyan 2008-04-01 01:06:42 EDT
Splash page is the same in both tabs, it just has a rotating banner image which
gets picked randomly each time you load the page.
Comment 7 petrosyan 2008-04-03 19:16:53 EDT
(In reply to comment #2)
> It's because the product page at mozilla.org is still missing. Will be fixed
> after final ff3 release.

Final FF3 is scheduled for June, while Fedora 9 is scheduled for end of April.
This means that this bug should be fixed before FF3 final release.
Comment 8 Matěj Cepl 2008-04-08 03:50:59 EDT
*** Bug 441374 has been marked as a duplicate of this bug. ***
Comment 9 Jon Stanley 2008-04-17 00:33:46 EDT
This doesn't happen for me anymore.  Can other folks confirm?
Comment 10 Jeremy Katz 2008-04-17 02:38:23 EDT
Booting today's livecd, I'm still seeing two tabs of start.fp.org when starting
firefox
Comment 11 Martin Stransky 2008-04-17 04:46:27 EDT
It's because the second tab is intended to be "a product" page (like
http://www.mozilla.com/en-US/products/firefox/3.0b5/releasenotes/). But this
page don't exist for our current fedora ff build (it's RC1 candidate??) so the
page shows our start page instead of the 404 error.

The "product" page is shown after first ff start after installation. I expect is
always for the Live CD. It will be fixed after final ff release.
Comment 12 Jeremy Katz 2008-04-17 09:55:16 EDT
I understand that, you understand that.  The user who installs Fedora 9 is just
going to see it and is going to have a bad impression based on something so
obvious and "in your face".  

And that's ignoring the question of what value there is in throwing the browser
release notes up the first time you start a browser... we don't pop up GNOME
release notes the first time you log in to the desktop. 
Comment 13 Martin Stransky 2008-04-17 10:50:12 EDT
Okay, i'll investigate how to disable the "whatsnew" tab.
Comment 14 Martin Stransky 2008-04-18 05:31:17 EDT
Fix added to firefox-3.0-0.55.beta5.fc9.
Comment 15 Jesse Keating 2008-04-18 13:53:47 EDT
That wasn't requested for f9-final tagging, is there a reason?
Comment 16 Christopher Aillon 2008-04-18 14:00:46 EDT
koji has been busted so the fix hasn't been built yet
Comment 17 Jon Stanley 2008-04-20 04:57:25 EDT
just needs tagging:

http://koji.fedoraproject.org/koji/buildinfo?buildID=46596
Comment 18 Bill Nottingham 2008-04-21 17:41:10 EDT
Verified.
Comment 19 lihuang 2008-07-30 22:54:55 EDT
verified this bug on firefox-3.0.1-1.fc9.i386

Note You need to log in before you can comment on or make changes to this bug.