Bug 437076 - kernel BUG at fs/gfs2/glock.c:1119
kernel BUG at fs/gfs2/glock.c:1119
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: GFS-kernel (Show other bugs)
8
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Abhijith Das
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 02:37 EDT by Eugenij Shkrigunov
Modified: 2008-10-07 06:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 06:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
part of /var/log/messages (11.80 KB, text/plain)
2008-03-25 02:35 EDT, Eugenij Shkrigunov
no flags Details

  None (edit)
Description Eugenij Shkrigunov 2008-03-12 02:37:53 EDT
kernel version 2.6.24.3-12.
There is part of /var/log/messages:
Mar 11 11:39:17 lts1 ccsd[5426]: Starting ccsd 2.02.00:
Mar 11 11:39:17 lts1 ccsd[5426]:  Built: Mar 11 2008 09:54:19
Mar 11 11:39:17 lts1 ccsd[5426]:  Copyright (C) Red Hat, Inc.  2004-2007  All 
rights reserved.
Mar 11 11:39:17 lts1 ccsd[5426]: /etc/cluster/cluster.conf (cluster name = 
cluster1, version = 7) found.
Mar 11 11:39:17 lts1 ccsd[5426]: Unable to perform sendto: Network is 
unreachable
Mar 11 11:39:46 lts1 ccsd[5426]:last message repeated 16 times
Mar 11 11:39:46 lts1 ccsd[5426]: Unable to connect to cluster infrastructure 
after 30 seconds.
Mar 11 11:39:47 lts1 ccsd[5426]: Unable to perform sendto: Network is 
unreachable
Mar 11 11:39:58 lts1 ccsd[5426]:last message repeated 6 times
Mar 11 11:39:58 lts1 ccsd[5426]: Initial status:: Quorate
Mar 11 11:41:29 lts1 gnbd_monitor[5505]: gnbd_monitor started. Monitoring 
device #0
Mar 11 11:41:29 lts1 gnbd_recvd[5508]: gnbd_recvd started
Mar 11 11:41:29 lts1 kernel: resending requests
Mar 11 11:43:00 lts1 kernel: dlm: Using TCP for communications
Mar 11 11:43:00 lts1 kernel: dlm: got connection from 1
Mar 11 11:43:00 lts1 kernel: dlm: got connection from 4
Mar 11 11:43:01 lts1 clvmd: Cluster LVM daemon started - connected to CMAN
Mar 11 11:43:07 lts1 kernel: GFS2: fsid=: Trying to join 
cluster "lock_dlm", "cluster1:home"
Mar 11 11:43:07 lts1 kernel: GFS2: fsid=cluster1:home.1: Joined cluster. Now 
mounting FS...
Mar 11 11:43:08 lts1 kernel: GFS2: fsid=cluster1:home.1: jid=1, already locked 
for use
Mar 11 11:43:08 lts1 kernel: GFS2: fsid=cluster1:home.1: jid=1: Looking at 
journal...
Mar 11 11:43:08 lts1 kernel: GFS2: fsid=cluster1:home.1: jid=1: Done
Mar 11 11:43:08 lts1 kernel: GFS2: fsid=cluster1:home.1: found 2 quota changes
Mar 11 11:58:01 lts1 ntpdate[5799]: step time server 10.101.100.241 offset 
0.664803 sec
Mar 11 12:00:24 lts1 kernel: 
Mar 11 12:00:24 lts1 kernel: Pid: 0, comm: swapper Not tainted 
(2.6.24.3-12.fc8PAE #1)
Mar 11 12:00:24 lts1 kernel: EIP: 0060:[<c04032a2>] EFLAGS: 00000246 CPU: 0
Mar 11 12:00:24 lts1 kernel: EIP is at mwait_idle_with_hints+0x3b/0x3f
Mar 11 12:00:24 lts1 kernel: EAX: 00000000 EBX: 00000000 ECX: 00000000 EDX: 
00000000
Mar 11 12:00:24 lts1 kernel: ESI: 00000000 EDI: c074b008 EBP: 00000020 ESP: 
c074bfbc
Mar 11 12:00:24 lts1 kernel:  DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Mar 11 12:00:24 lts1 kernel: CR0: 8005003b CR2: 080f9cb8 CR3: 3683e000 CR4: 
000006f0
Mar 11 12:00:24 lts1 kernel: DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 
00000000
Mar 11 12:00:24 lts1 kernel: DR6: ffff0ff0 DR7: 00000400
Mar 11 12:00:24 lts1 kernel:  [<c04032a6>] mwait_idle+0x0/0x13
Mar 11 12:00:24 lts1 kernel:  [<c0403653>] cpu_idle+0xac/0xcd
Mar 11 12:00:24 lts1 kernel:  [<c07509df>] start_kernel+0x336/0x33e
Mar 11 12:00:24 lts1 kernel:  [<c07500e0>] unknown_bootoption+0x0/0x195
Mar 11 12:00:24 lts1 kernel:  =======================
Mar 11 12:00:24 lts1 kernel: 
Mar 11 12:00:24 lts1 kernel: Pid: 0, comm: swapper Not tainted 
(2.6.24.3-12.fc8PAE #1)
Mar 11 12:00:24 lts1 kernel: EIP: 0060:[<c04032a2>] EFLAGS: 00000246 CPU: 0
Mar 11 12:00:24 lts1 kernel: EIP is at mwait_idle_with_hints+0x3b/0x3f
Mar 11 12:00:24 lts1 kernel: EAX: 00000000 EBX: 00000000 ECX: 00000000 EDX: 
00000000
Mar 11 12:00:24 lts1 kernel: ESI: 00000000 EDI: c074b008 EBP: 00000020 ESP: 
c074bfbc
Mar 11 12:00:24 lts1 kernel:  DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Mar 11 12:00:24 lts1 kernel: CR0: 8005003b CR2: 080f9cb8 CR3: 3683e000 CR4: 
000006f0
Mar 11 12:00:24 lts1 kernel: DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 
00000000
Mar 11 12:00:24 lts1 kernel: DR6: ffff0ff0 DR7: 00000400
Mar 11 12:00:24 lts1 kernel:  [<c04032a6>] mwait_idle+0x0/0x13
Mar 11 12:00:24 lts1 kernel:  [<c0403653>] cpu_idle+0xac/0xcd
Mar 11 12:00:24 lts1 kernel:  [<c07509df>] start_kernel+0x336/0x33e
Mar 11 12:00:24 lts1 kernel:  [<c07500e0>] unknown_bootoption+0x0/0x195
Mar 11 12:00:24 lts1 kernel:  =======================
Mar 11 12:00:50 lts1 kernel: dlm: closing connection to node 4
Mar 11 12:00:50 lts1 fenced[5451]: fencing deferred to storage1-p
Mar 11 12:00:55 lts1 kernel: GFS2: fsid=cluster1:home.1: jid=0: Trying to 
acquire journal lock...
Mar 11 12:00:55 lts1 kernel: GFS2: fsid=cluster1:home.1: jid=0: Looking at 
journal...
Mar 11 12:00:55 lts1 kernel: GFS2: fsid=cluster1:home.1: jid=0: Done
Mar 11 12:00:55 lts1 kernel: original: gfs2_rindex_hold+0x2a/0x18d [gfs2]
Mar 11 12:00:55 lts1 kernel: pid : 5613
Mar 11 12:00:55 lts1 kernel: lock type : 2 lock state : 3
Mar 11 12:00:55 lts1 kernel: new: gfs2_rindex_hold+0x2a/0x18d [gfs2]
Mar 11 12:00:55 lts1 kernel: pid : 5613
Mar 11 12:00:55 lts1 kernel: lock type : 2 lock state : 3
Mar 11 12:00:55 lts1 kernel: ------------[ cut here ]------------
Mar 11 12:00:55 lts1 kernel: kernel BUG at fs/gfs2/glock.c:1119!
Mar 11 12:00:55 lts1 kernel: invalid opcode: 0000 [#1] SMP 
Mar 11 12:00:55 lts1 kernel: Modules linked in: gnbd(U) lock_dlm gfs2 dlm 
configfs ipip tunnel4 8021q dm_multipath e1000 i5000_edac edac_core iTCO_wdt 
iTCO_vendor_support i2c_i801 sr_mod button pcspkr cdrom i2c_core sg 
dm_snapshot dm_zero dm_mirror dm_mod ata_piix ata_generic pata_acpi libata 
sd_mod scsi_mod raid456 async_xor async_memcpy async_tx xor raid1 ext3 jbd 
mbcache uhci_hcd ohci_hcd ehci_hcd
Mar 11 12:00:55 lts1 kernel: 
Mar 11 12:00:55 lts1 kernel: Pid: 5613, comm: gfs2_quotad Not tainted 
(2.6.24.3-12.fc8PAE #1)
Mar 11 12:00:55 lts1 kernel: EIP: 0060:[<f8ba63f9>] EFLAGS: 00010292 CPU: 7
Mar 11 12:00:55 lts1 kernel: EIP is at gfs2_glock_nq+0x109/0x1a4 [gfs2]
Mar 11 12:00:55 lts1 kernel: EAX: 00000020 EBX: f4d45c60 ECX: 00000046 EDX: 
00000000
Mar 11 12:00:55 lts1 kernel: ESI: f4d45c60 EDI: f60ffbc8 EBP: f60ffbc8 ESP: 
f4957df8
Mar 11 12:00:55 lts1 kernel:  DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Mar 11 12:00:55 lts1 kernel: Process gfs2_quotad (pid: 5613, ti=f4957000 
task=f44ced20 task.ti=f4957000)
Mar 11 12:00:55 lts1 kernel: Stack: f8bbc6ac 00000002 00000003 f5894000 
00000000 f60ffbc8 f5894000 f4d45350 
Mar 11 12:00:55 lts1 kernel:        f6c83b88 f8bb6782 f4d45c60 f8ba62de 
00000000 f60ffd98 f4d45c60 f8bbb0a0 
Mar 11 12:00:55 lts1 kernel:        000015ed f4d45c84 f467f9f8 f467f9f8 
f8ba6465 00000000 f8ba7fa7 0000e7ec 
Mar 11 12:00:55 lts1 kernel: Call Trace:
Mar 11 12:00:55 lts1 kernel:  [<f8bb6782>] gfs2_rindex_hold+0x33/0x18d [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8ba62de>] glock_wait_internal+0x1e5/0x1f7 
[gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8ba6465>] gfs2_glock_nq+0x175/0x1a4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8ba7fa7>] gfs2_inode_refresh+0x40b/0x420 
[gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb71ab>] gfs2_inplace_reserve_i+0xa2/0x572 
[gfs2]
Mar 11 12:00:55 lts1 kernel:  [<c062dd4a>] down_read+0x17/0x25
Mar 11 12:00:55 lts1 kernel:  [<f8baaca5>] gfs2_log_reserve+0x106/0x117 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bba573>] gfs2_trans_begin+0xda/0x10e [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb4154>] do_sync+0x2c4/0x5d4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bac70d>] gfs2_meta_wait+0x24/0x87 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb3a1e>] bh_get+0x189/0x193 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb3f9a>] do_sync+0x10a/0x5d4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb4d2a>] gfs2_quota_sync+0x1fe/0x281 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8b9e545>] gfs2_quotad+0xb1/0x140 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8b9e494>] gfs2_quotad+0x0/0x140 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8b9e494>] gfs2_quotad+0x0/0x140 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<c043fd30>] kthread+0x38/0x60
Mar 11 12:00:55 lts1 kernel:  [<c043fcf8>] kthread+0x0/0x60
Mar 11 12:00:55 lts1 kernel:  [<c0405e0b>] kernel_thread_helper+0x7/0x10
Mar 11 12:00:55 lts1 kernel:  =======================
Mar 11 12:00:55 lts1 kernel: Code: 0c c7 04 24 9f c6 bb f8 89 44 24 04 e8 d3 
a0 88 c7 8b 47 20 8b 57 14 89 44 24 08 89 54 24 04 c7 04 24 ac c6 bb f8 e8 b9 
a0 88 c7 <0f> 0b eb fe 39 58 0c 74 0e 89 d0 8b 10 0f 18 02 90 39 c8 75 ef 
Mar 11 12:00:55 lts1 kernel: EIP: [<f8ba63f9>] gfs2_glock_nq+0x109/0x1a4 
[gfs2] SS:ESP 0068:f4957df8
Mar 11 12:00:55 lts1 kernel: ---[ end trace 3bdfdb109a4e6ff0 ]---
Mar 11 12:00:55 lts1 kernel: ------------[ cut here ]------------
Mar 11 12:00:55 lts1 kernel: kernel BUG at fs/jbd/transaction.c:275!
Mar 11 12:00:55 lts1 kernel: invalid opcode: 0000 [#2] SMP 
Mar 11 12:00:55 lts1 kernel: Modules linked in: gnbd(U) lock_dlm gfs2 dlm 
configfs ipip tunnel4 8021q dm_multipath e1000 i5000_edac edac_core iTCO_wdt 
iTCO_vendor_support i2c_i801 sr_mod button pcspkr cdrom i2c_core sg 
dm_snapshot dm_zero dm_mirror dm_mod ata_piix ata_generic pata_acpi libata 
sd_mod scsi_mod raid456 async_xor async_memcpy async_tx xor raid1 ext3 jbd 
mbcache uhci_hcd ohci_hcd ehci_hcd
Mar 11 12:00:55 lts1 kernel: 
Mar 11 12:00:55 lts1 kernel: Pid: 5613, comm: gfs2_quotad Tainted: G      D 
(2.6.24.3-12.fc8PAE #1)
Mar 11 12:00:55 lts1 kernel: EIP: 0060:[<f8860b01>] EFLAGS: 00010283 CPU: 7
Mar 11 12:00:55 lts1 kernel: EIP is at journal_start+0x2f/0xa9 [jbd]
Mar 11 12:00:55 lts1 kernel: EAX: f8bb4082 EBX: f59ea9c0 ECX: f685d000 EDX: 
0000000a
Mar 11 12:00:55 lts1 kernel: ESI: f7bdec00 EDI: f5cfee28 EBP: 0000000a ESP: 
f495797c
Mar 11 12:00:55 lts1 kernel:  DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Mar 11 12:00:55 lts1 kernel: Process gfs2_quotad (pid: 5613, ti=f4957000 
task=f44ced20 task.ti=f4957000)
Mar 11 12:00:55 lts1 kernel: Stack: f59ea9c0 c94ee4c0 0006a900 f5cfee28 
f5cfeed0 f8892afa f70ae000 00000001 
Mar 11 12:00:55 lts1 kernel:        f54a30b0 c05d876f f7860000 00000286 
00000246 f50c9300 0000000a 00000000 
Mar 11 12:00:55 lts1 kernel:        0000006a 00000900 00000940 00000000 
00000040 0006a900 00000000 00000700 
Mar 11 12:00:55 lts1 kernel: Call Trace:
Mar 11 12:00:55 lts1 kernel:  [<f8892afa>] ext3_write_begin+0x77/0x18a [ext3]
Mar 11 12:00:55 lts1 kernel:  [<c05d876f>] __qdisc_run+0x97/0x169
Mar 11 12:00:55 lts1 kernel:  [<c046aca8>] 
generic_file_buffered_write+0x109/0x5ac
Mar 11 12:00:55 lts1 kernel:  [<c04a1d62>] generic_getxattr+0x3e/0x44
Mar 11 12:00:55 lts1 kernel:  [<c04a1d24>] generic_getxattr+0x0/0x44
Mar 11 12:00:55 lts1 kernel:  [<c046b5dc>] 
__generic_file_aio_write_nolock+0x491/0x4f0
Mar 11 12:00:55 lts1 kernel:  [<c04255b6>] __wake_up_locked+0x1c/0x1f
Mar 11 12:00:55 lts1 kernel:  [<c046b690>] generic_file_aio_write+0x55/0xb3
Mar 11 12:00:55 lts1 kernel:  [<f888efc4>] ext3_file_write+0x24/0x8f [ext3]
Mar 11 12:00:55 lts1 kernel:  [<c048ba81>] do_sync_write+0xc7/0x10a
Mar 11 12:00:55 lts1 kernel:  [<c043fdf9>] autoremove_wake_function+0x0/0x35
Mar 11 12:00:55 lts1 kernel:  [<c0444b71>] getnstimeofday+0x30/0xbf
Mar 11 12:00:55 lts1 kernel:  [<c0454305>] do_acct_process+0x586/0x5ad
Mar 11 12:00:55 lts1 kernel:  [<c050260a>] vsnprintf+0x449/0x485
Mar 11 12:00:55 lts1 kernel:  [<c04255b6>] __wake_up_locked+0x1c/0x1f
Mar 11 12:00:55 lts1 kernel:  [<c062cb9f>] __down_trylock+0x3b/0x44
Mar 11 12:00:55 lts1 kernel:  [<c062e59b>] __down_failed_trylock+0x7/0xc
Mar 11 12:00:55 lts1 kernel:  [<c04545a6>] acct_process+0x3b/0x45
Mar 11 12:00:55 lts1 kernel:  [<c04327e2>] do_exit+0x21c/0x695
Mar 11 12:00:55 lts1 kernel:  [<c04304cd>] printk+0x1b/0x1f
Mar 11 12:00:55 lts1 kernel:  [<c0406785>] die+0x21d/0x224
Mar 11 12:00:55 lts1 kernel:  [<c04069ab>] do_invalid_op+0x0/0x8a
Mar 11 12:00:55 lts1 kernel:  [<c0406a2c>] do_invalid_op+0x81/0x8a
Mar 11 12:00:55 lts1 kernel:  [<f8ba63f9>] gfs2_glock_nq+0x109/0x1a4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<c042ff90>] release_console_sem+0x187/0x1a0
Mar 11 12:00:55 lts1 kernel:  [<c04645c4>] delayacct_end+0x70/0x77
Mar 11 12:00:55 lts1 kernel:  [<c0469d52>] find_lock_page+0x19/0x7f
Mar 11 12:00:55 lts1 kernel:  [<c046c009>] find_or_create_page+0x1e/0x95
Mar 11 12:00:55 lts1 kernel:  [<f8bac53c>] getbuf+0xf8/0x102 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<c062eb62>] error_code+0x72/0x78
Mar 11 12:00:55 lts1 kernel:  [<f8ba63f9>] gfs2_glock_nq+0x109/0x1a4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb6782>] gfs2_rindex_hold+0x33/0x18d [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8ba62de>] glock_wait_internal+0x1e5/0x1f7 
[gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8ba6465>] gfs2_glock_nq+0x175/0x1a4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8ba7fa7>] gfs2_inode_refresh+0x40b/0x420 
[gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb71ab>] gfs2_inplace_reserve_i+0xa2/0x572 
[gfs2]
Mar 11 12:00:55 lts1 kernel:  [<c062dd4a>] down_read+0x17/0x25
Mar 11 12:00:55 lts1 kernel:  [<f8baaca5>] gfs2_log_reserve+0x106/0x117 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bba573>] gfs2_trans_begin+0xda/0x10e [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb4154>] do_sync+0x2c4/0x5d4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bac70d>] gfs2_meta_wait+0x24/0x87 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb3a1e>] bh_get+0x189/0x193 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb3f9a>] do_sync+0x10a/0x5d4 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8bb4d2a>] gfs2_quota_sync+0x1fe/0x281 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8b9e545>] gfs2_quotad+0xb1/0x140 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8b9e494>] gfs2_quotad+0x0/0x140 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<f8b9e494>] gfs2_quotad+0x0/0x140 [gfs2]
Mar 11 12:00:55 lts1 kernel:  [<c043fd30>] kthread+0x38/0x60
Mar 11 12:00:55 lts1 kernel:  [<c043fcf8>] kthread+0x0/0x60
Mar 11 12:00:55 lts1 kernel:  [<c0405e0b>] kernel_thread_helper+0x7/0x10
Mar 11 12:00:55 lts1 kernel:  =======================
Mar 11 12:00:55 lts1 kernel: Code: 56 89 c6 53 bb e2 ff ff ff 83 ec 04 64 a1 
00 10 79 c0 8b 80 d8 05 00 00 85 f6 89 04 24 74 7e 85 c0 74 11 89 c3 8b 00 39 
30 74 04 <0f> 0b eb fe ff 43 08 eb 69 a1 08 9e 86 f8 ba 50 00 00 00 bb f4 
Mar 11 12:00:55 lts1 kernel: EIP: [<f8860b01>] journal_start+0x2f/0xa9 [jbd] 
SS:ESP 0068:f495797c
Mar 11 12:00:55 lts1 kernel: ---[ end trace 3bdfdb109a4e6ff0 ]---
Mar 11 12:00:55 lts1 kernel: Fixing recursive fault but reboot is needed!
Comment 1 Steve Whitehouse 2008-03-12 09:16:50 EDT
What kind of load was the filesystem under when this happened?

It looks like a quota problem, so I presume that you had quotas turned on?

Its just possible this is a bug thats fixed in upstream but hasn't made it into
F-8 yet, but at first glance it looks like its probably something new, so any
extra information that you can give us would be very helpful at this stage.
Comment 2 Eugenij Shkrigunov 2008-03-12 11:03:49 EDT
Load was very few, almost none at all:
11:43:07  mount gfs2
12:00:24  beginning of problem
for that period read/write I/O ~ 1..10Mb

Quota is turned off:
there is string from /etc/fstab
/dev/vg_cluster1/lv_home    /home   gfs2   
defaults,nodev,nosuid,noatime,nodiratime,acl,quota=off   0 0

What kind of extra information maybe useful for you? I will try do my best to 
collect such information. I am sorry for my English.
Comment 3 Eugenij Shkrigunov 2008-03-25 02:35:21 EDT
Created attachment 298978 [details]
part of /var/log/messages

The same in kernel-2.6.24.3-34.fc8PAE
Comment 4 Steve Whitehouse 2008-04-21 03:50:18 EDT
Abhi, how far have you got with this? I've just had another report of the same
thing.
Comment 5 Rumen B. 2008-04-21 04:36:45 EDT
Steve, here is what you have been asking for:

GFS2 (built Apr 19 2008 11:29:07) installed
GFS2: fsid=: Trying to join cluster "lock_nolock", "sdb"
Lock_Nolock (built Apr 19 2008 11:29:31) installed
GFS2: fsid=sdb.0: Joined cluster. Now mounting FS...
GFS2: fsid=sdb.0: jid=0, already locked for use
GFS2: fsid=sdb.0: jid=0: Looking at journal...
GFS2: fsid=sdb.0: jid=0: Done
mtrr: your processor doesn't support write-combining
------------[ cut here ]------------
kernel BUG at fs/gfs2/rgrp.c:822!
invalid opcode: 0000 [#1] SMP 
Modules linked in: lock_nolock gfs2 nls_utf8 rfcomm l2cap bluetooth autofs4 fuse
sunrpc loop dm_multipath ipv6 parport_pc parport floppy ac button pcnet32 pcspkr
i2c_piix4 mii i2c_core sr_mod cdrom sg BusLogic dm_snapshot dm_zero dm_mirror
dm_mod pata_acpi ata_generic ata_piix libata sd_mod scsi_mod ext3 jbd mbcache
uhci_hcd ohci_hcd ehci_hcd

Pid: 2469, comm: gfs2_quotad Not tainted (2.6.24.4-84.fc8 #1)
EIP: 0060:[<e930b6ff>] EFLAGS: 00010286 CPU: 0
EIP is at gfs2_alloc_get+0xc/0x27 [gfs2]
EAX: da200000 EBX: da200000 ECX: da200000 EDX: 00000000
ESI: d0048400 EDI: 000157c0 EBP: 00000000 ESP: e6ec2ee8
 DS: 007b ES: 007b FS: 00d8 GS: 0000 SS: 0068
Process gfs2_quotad (pid: 2469, ti=e6ec2000 task=d001ad20 task.ti=e6ec2000)
Stack: da2000a8 e930937f 00000058 e6ec2f74 00000000 d0048700 00000002 e7888000 
       da200000 e7ae00c0 00000002 e6c6cb00 00000002 e9308c71 000007c0 00000005 
       00000000 d0048700 00000000 e72fc1f8 e72fc1f8 e72fc1c0 000009a5 00000001 
Call Trace:
 [<e930937f>] do_sync+0x2a5/0x623 [gfs2]
 [<e9308c71>] bh_get+0x189/0x193 [gfs2]
 [<e93091e4>] do_sync+0x10a/0x623 [gfs2]
 [<e9309fc9>] gfs2_quota_sync+0x1fe/0x281 [gfs2]
 [<e92f35a5>] gfs2_quotad+0xb1/0x140 [gfs2]
 [<e92f34f4>] gfs2_quotad+0x0/0x140 [gfs2]
 [<e92f34f4>] gfs2_quotad+0x0/0x140 [gfs2]
 [<c043edf0>] kthread+0x38/0x60
 [<c043edb8>] kthread+0x0/0x60
 [<c0406467>] kernel_thread_helper+0x7/0x10
 =======================
Code: 03 56 08 89 7c 24 04 89 1c 24 e8 3f fe ff ff 8b 46 0c 8d 1c 83 83 c4 18 89
d8 5b 5e 5f 5d c3 53 89 c3 83 b8 ec 01 00 00 00 74 04 <0f> 0b eb fe ba d0 80 00
00 b8 80 76 74 c0 e8 3b 9c 17 d7 89 83 
EIP: [<e930b6ff>] gfs2_alloc_get+0xc/0x27 [gfs2] SS:ESP 0068:e6ec2ee8
---[ end trace c92b7ce1ca2e30db ]---


I have got this when I tried to mount new gfs2 on /home, create new user, login
as this user and do some read/write to the gfs2.
Comment 6 Abhijith Das 2008-04-24 19:09:33 EDT
Ok... I think I know what's going on. This seems to be happening because of the
quota-unstuffing issue (bug 434736) that was fixed for RHEL5 and upstream. The
fix probably didn't make it into your kernels.

Please try your tests with this patch to see if it fixes your issues. If not, we
might have something else on our hands.

http://git.kernel.org/?p=linux/kernel/git/steve/gfs2-2.6-nmw.git;a=commitdiff;h=20b95bf2c4c5c28e093aa42699e67829b6cd7fd0
Comment 7 Steve Whitehouse 2008-06-04 08:24:06 EDT
Pushing the severity down since we belive we have already fixed this and are
awaiting confirmation of that.
Comment 8 Steve Whitehouse 2008-10-07 06:39:57 EDT
Since we've had no further info, I'll assume that this is fixed and close it.

Note You need to log in before you can comment on or make changes to this bug.