This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 437080 - 'hup' without an argument can also be used via pipe
'hup' without an argument can also be used via pipe
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tcsh617 (Show other bugs)
5.1
i386 Linux
low Severity low
: rc
: ---
Assigned To: Vojtech Vitek
BaseOS QE - Apps
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 03:03 EDT by Cai Xianchao
Modified: 2015-03-04 18:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The tcsh(1) man page inaccurately stated that the "hup" and "nohup" built-in commands, when used without an argument, can be used only within a shell script. The man page has been corrected: it now states that the hup and nohup built-in commands can be used when running the shell non-interactively.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 04:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is a patch fixing the bug. (629 bytes, patch)
2008-03-12 03:03 EDT, Cai Xianchao
no flags Details | Diff
Simple patch to fix 'hup' section of man page (623 bytes, patch)
2011-01-17 11:25 EST, Vojtech Vitek
no flags Details | Diff

  None (edit)
Description Cai Xianchao 2008-03-12 03:03:41 EDT
Description of problem:

Manpage says that "Without  an  argument  (allowed  in only  a  shell 
script),", but it is allowed via pipe.

Version-Release number of selected component (if applicable):
tcsh-6.15.00

How reproducible:


Steps to Reproduce:
1.[test@localhost ~]$ hup
hup: Can't from terminal.

2.[test@localhost ~]$ echo 'hup' | tcsh -l
  
Actual results:
Nothing is outputed.

Expected results:
An error message is outputed.

Additional info:
Comment 1 Cai Xianchao 2008-03-12 03:03:41 EDT
Created attachment 297728 [details]
This is a patch fixing the bug.
Comment 2 RHEL Product and Program Management 2011-01-11 14:57:52 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-12 10:14:40 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 Vojtech Vitek 2011-01-17 11:25:05 EST
Created attachment 473880 [details]
Simple patch to fix 'hup' section of man page

Will be proposed to upstream.
Comment 9 Vojtech Vitek 2011-04-15 12:41:02 EDT
Proposed to upstream: http://bugs.gw.com/view.php?id=119
Comment 10 Vojtech Vitek 2011-04-18 04:26:52 EDT
Accepted by upstream (tcsh 6.17.07b).
Comment 12 Miroslav Svoboda 2011-07-01 17:48:26 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The tcsh(1) man page inaccurately stated that the "hup" and "nohup" built-in commands, when used without an argument, can be used only within a shell script. The man page has been corrected: it now states that the hup and nohup built-in commands can be used when running the shell non-interactively.
Comment 13 errata-xmlrpc 2011-07-21 04:49:29 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html
Comment 14 errata-xmlrpc 2011-07-21 08:09:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1072.html

Note You need to log in before you can comment on or make changes to this bug.