Bug 437081 - X not starting with cirrus driver
X not starting with cirrus driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-cirrus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 05:18 EDT by Jens Petersen
Modified: 2008-03-19 02:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 02:30:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (24.16 KB, text/plain)
2008-03-12 21:09 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2008-03-12 05:18:15 EDT
Description of problem:
I can start X in qemu with current rawhide.
This looks very similar to bug 436684 for trident.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9

How reproducible:
every time

Steps to Reproduce:
1. install rawhide in qemu
2.
3.
  
Actual results:
no X

Expected results:
X

Additional info:
vesa driver works
More details later if you need them.
Comment 1 Matěj Cepl 2008-03-12 06:04:32 EDT
Sure, /var/log/Xorg.0.log from broken qemu machine would be helpful. Also, is
this kvm (hw-accelerated virtual machine) or just plain-ol' qemu.
Comment 2 Jens Petersen 2008-03-12 20:59:55 EDT
Hmm maybe it is a different issue since it still seems to happen with
xorg-x11-server-1.4.99.901-5.20080310.fc9.(In reply to comment #1)

> Also, is this kvm (hw-accelerated virtual machine) or just plain-ol' qemu.

Yes, it is kvm.
Comment 3 Jens Petersen 2008-03-12 21:09:25 EDT
Created attachment 297873 [details]
Xorg.0.log
Comment 4 Jens Petersen 2008-03-12 22:50:26 EDT
Funny thing is now I can't even get X to start with the vesa driver??
Comment 5 Dave Airlie 2008-03-12 22:59:16 EDT
okay cirrus has a bug with no xorg.conf file provided.

http://koji.fedoraproject.org/packages/xorg-x11-drv-cirrus/1.1.0/9.fc9/

new packages are there. I'll bug rel eng to tag it in.
Comment 6 Jens Petersen 2008-03-12 23:14:17 EDT
Great fixes it for me, thanks!

Note You need to log in before you can comment on or make changes to this bug.