Bug 437091 - RFE: include toshbt in the kernel
RFE: include toshbt in the kernel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
http://0bits.com/toshbt/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 07:44 EDT by Rene Rask
Modified: 2013-01-10 02:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-28 14:08:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Module source in case the site goes away. (4.41 KB, application/x-gzip)
2008-03-12 07:45 EDT, Rene Rask
no flags Details

  None (edit)
Description Rene Rask 2008-03-12 07:44:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Description of problem:
I found a module which allows me to use the internel bluetooth adaptor in my laptop. This would be nice to have in the kernel.
Maybe it just needs to be added to the toshiba_acpi kernel module.
This works for me on my Toshiba Qosmio G30-163 laptop.

Version-Release number of selected component (if applicable):
2.6.25-0.105.rc5.fc9

How reproducible:
Always


Steps to Reproduce:
1. insmod toshiba_acpi and the toshbt module.


Actual Results:
Bluetooth usb devices was powered on and attached. The regular bluetooth framework took over and it works.

Expected Results:


Additional info:
Comment 1 Rene Rask 2008-03-12 07:45:48 EDT
Created attachment 297751 [details]
Module source in case the site goes away.
Comment 2 Jon Stanley 2008-04-23 16:30:34 EDT
Adding FutureFeature keyword to RFE's.
Comment 3 Matthew Garrett 2008-05-20 14:14:22 EDT
I'm not enthusiastic about this as-is. It duplicates a lot of the toshiba_acpi
code and provides a custom interface in /proc. I'd prefer to merge this into
toshiba_acpi and add an rfkill interface to make it easier to deal with.
Comment 4 Paul W. Frields 2008-08-10 15:54:41 EDT
Triaged
Comment 5 Gianluca Sforna 2008-11-03 04:33:08 EST
The code for activating the bluetooth radio is now merged in 2.6.28-rc1.

The relevant commit is:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=c41a40c58b623f97dd2e23aa3baab2cedb47d99f

but there are probably a couple more you want to pickup anyway.

Can we apply a patch to the Fedora kernel until we rebase on 2.6.28?

Otherwise we will continue to have broken support for these laptops for quite some time..
Comment 6 Matthew Garrett 2008-11-03 07:22:16 EST
Commited to rawhide CVS
Comment 7 Gianluca Sforna 2008-11-03 17:40:44 EST
Hi Matthew, thanks a lot for your quick reaction.

I just checked the patch in cvs and I think it's possible you pulled an incomplete patch as it seems missing the Kconfig added flags.

To be sure, you probably want to use the plain version of the diff:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=c41a40c58b623f97dd2e23aa3baab2cedb47d99f

Sorry for the hassle
Comment 8 Matthew Garrett 2008-11-03 18:32:30 EST
The Kconfig dependencies are always selected in our kernel, so it's more cosmetic than anything else.
Comment 9 Gianluca Sforna 2008-11-03 18:53:31 EST
OK. I hope it will appear in a F10 kernel soon...
Comment 10 Chuck Ebbert 2009-02-28 14:08:48 EST
Shipped in F10 and is also in F11 rawhide.
Comment 11 Gianluca Sforna 2009-03-01 03:51:02 EST
Yeah. I just need to note bluetooth works as expected only with a full boot. After a suspend/resume cycle it is not reactivated.

I'd need to check if 2.6.29 fixes the issue...

Note You need to log in before you can comment on or make changes to this bug.