Bug 437100 - rt3 unable to log into /var/log/rt3/rt.log
rt3 unable to log into /var/log/rt3/rt.log
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rt3 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 09:31 EDT by Xavier Bachelot
Modified: 2008-04-10 13:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-10 13:08:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Bachelot 2008-03-12 09:31:50 EDT
Description of problem:
rt3 is unable to log into its default log file.

Version-Release number of selected component (if applicable):
rt3-3.6.6

How reproducible:
always

Steps to Reproduce:
1. install rt3 
2. add Set($LogToFile      , 'error'); to RT-SiteConfig.pm
3. start apache
4. log into rt3
  
Actual results:
Internal server error 

Expected results:
rt3 works

Additional info:
/var/log/rt3 should be owned by apache or at least an empty /var/log/rt3/rt.log
owned by apache should be packaged.
This applies to F7 and F8 packages too.
Comment 1 Xavier Bachelot 2008-03-12 10:41:52 EDT
On a related matter, no logrotate conf is shipped.
Something like that should do :
/var/log/rt3/rt.log {
    compress
    missingok
    notifempty
    rotate 5
    size 100k
}
Comment 2 Fedora Update System 2008-03-17 06:53:21 EDT
rt3-3.6.5-2.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-03-17 06:54:17 EDT
rt3-3.6.3-3.fc7 has been submitted as an update for Fedora 7
Comment 4 Fedora Update System 2008-03-21 18:19:08 EDT
rt3-3.6.3-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rt3'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2644
Comment 5 Xavier Bachelot 2008-03-26 09:10:45 EDT
There's typo in the commit and thus the logrotate file is created as
rt3.logrotate in a rt3 subdir :

--- rt3.spec.orig       2008-03-26 14:05:39.000000000 +0100
+++ rt3.spec    2008-03-26 14:06:53.000000000 +0100
@@ -210,7 +210,7 @@
 install -d -m755 ${RPM_BUILD_ROOT}%{RT3_LOGDIR}

 # install log rotation stuff
-mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/rt3
+mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d
 install -m 644 rt3.logrotate ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/rt3

 install -d -m755 ${RPM_BUILD_ROOT}%{RT3_LOCALSTATEDIR}
Comment 6 Xavier Bachelot 2008-04-09 06:25:02 EDT
What is currently in cvs works for me, thanks.

Note You need to log in before you can comment on or make changes to this bug.