Bug 437104 - RFE: add Provides: ldif2ldbm to rpm
RFE: add Provides: ldif2ldbm to rpm
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.2.6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
:
Depends On:
Blocks: 436274 389_1.3.0
  Show dependency treegraph
 
Reported: 2008-03-12 09:51 EDT by Jan Safranek
Modified: 2015-12-10 13:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 13:37:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
git patch file (master) (1.08 KB, patch)
2012-02-14 13:39 EST, Noriko Hosoi
no flags Details | Diff

  None (edit)
Description Jan Safranek 2008-03-12 09:51:39 EDT
PADL migration tools can work both with OpenLDAP and Fedora-DS LDAP servers.
Currently the migrationtools package requires openldap-servers, which are not
necessary if the admin wants to migrate users/services/whatever into Fedora-DS
database.

It would be much better, if migrationtools would Require: ldib2ldbm and both
openldap-servers and fedora-ds-base would provide it - openldap-servers would
not be needed when fedora-ds-base is installed.
Comment 1 Paul W. Frields 2008-08-10 15:57:16 EDT
Triaged
Comment 2 Martin Kosek 2012-01-04 08:45:22 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/124
Comment 3 Noriko Hosoi 2012-02-13 14:41:58 EST
Hello Jan,

Sorry about this slow response.  Finally, we are ready to cover bugs including this one.

May we ask if this bug is still active?  The utility ldif2ldbm is not a part of openldap 2.x.  Instead, "slapadd" command is recommended to use.  The equivalent tool on 389-ds-base is ldif2db(.pl).

Thanks,
--noriko
Comment 4 Jan Safranek 2012-02-14 02:53:58 EST
This request originally came from Fedora-DS guys in bug #436274. Since that, OpenLDAP had Provides: ldib2ldbm, but it has been removed during recent cleanup as it was useless...

So, we can start again.

Jan, Noriko, please add Provides: ldib2ldbm to your spec files in Rawhide and let me know when it's ready, I'll update migrationtools afterwards.

> The utility ldif2ldbm is not a part of
> openldap 2.x.  Instead, "slapadd" command is recommended to use.  The
> equivalent tool on 389-ds-base is ldif2db(.pl).

Yes, 'ldib2ldbm' is not name of *utility* but name of *functionality* both packages provide. OpenLDAP via slapadd tool and Fedora-DS as ldif2db.pl
Comment 5 Jan Vcelak 2012-02-14 03:47:34 EST
I'm going to rebase OpenLDAP in Rawhide very soon - hopefully today. I will include the change.
Comment 6 Noriko Hosoi 2012-02-14 13:39:30 EST
Created attachment 562010 [details]
git patch file (master)

The attached patch has been pushed to master.

$ git push
Counting objects: 5, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 419 bytes, done.
Total 3 (delta 2), reused 0 (delta 0)
To ssh://pkgs.fedoraproject.org/389-ds-base.git
   6453827..2f38a74  master -> master
Comment 7 Jan Vcelak 2012-02-15 09:07:44 EST
(In reply to comment #5)
> I'm going to rebase OpenLDAP in Rawhide very soon - hopefully today. I will
> include the change.

Fixed in openldap-2.4.29-1.fc{17,18}
Comment 8 Jan Safranek 2012-02-20 08:23:20 EST
migrationtools-47-11.fc17 is heading to F17-testing and F18/Rawhide
Comment 9 Jan Safranek 2012-02-20 09:22:54 EST
(In reply to comment #4)
> This request originally came from Fedora-DS guys in bug #436274. Since that,
> OpenLDAP had Provides: ldib2ldbm, but it has been removed during recent cleanup
> as it was useless...
> 
> So, we can start again.
> 
> Jan, Noriko, please add Provides: ldib2ldbm to your spec files in Rawhide and
> let me know when it's ready, I'll update migrationtools afterwards.

Oops, stupid typo, it should be ldif2ldbm, not ldib2... Sorry.
Comment 10 Jan Vcelak 2012-02-20 09:52:53 EST
(In reply to comment #9)
> Oops, stupid typo, it should be ldif2ldbm, not ldib2... Sorry.

Fixed in openldap-2.4.29-2.fc{17,18}

Note You need to log in before you can comment on or make changes to this bug.