Bug 437111 - Saving a domain breaks due to connection sharing
Saving a domain breaks due to connection sharing
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 10:28 EDT by Soren Hansen
Modified: 2008-12-21 03:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-21 03:27:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soren Hansen 2008-03-12 10:28:46 EDT
Description of problem:


Version-Release number of selected component (if applicable):
0.5.3


How reproducible:
Always

Steps to Reproduce:
1. Start a domain
2. In its menu, click save and enter a filename
3. Wait a little bit

  
Actual results:
Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 403, in _save_callback
    vm.save(file_to_save)
  File "/usr/share/virt-manager/virtManager/domain.py", line 394, in save
    self.vm.save(file)
  File "/usr/lib/python2.5/site-packages/libvirt.py", line 354, in save
    if ret == -1: raise libvirtError ('virDomainSave() failed', dom=self)
libvirtError: virDomainSave() failed unknown procedure (received 34, expected 37)

Expected results:
Saving the image and not much else.

Additional info:
The problem seems to stem from virt-manager using the existing "control"
connection to invoke the saving. According to rjones, virt-manager should use
another connection for that.

First reported at:
https://bugs.edge.launchpad.net/ubuntu/+source/virt-manager/+bug/201221
Comment 1 Cole Robinson 2008-03-20 11:52:10 EDT
Hmm, this confuses me. Is this a bug at the libvirt level? Why should a seperate
connection be needed for saving? What type of connection and guest are you
using? (system or session, plain qemu or kvm, xen?). I can't seem to reproduce
this either.

That being said, I've noticed that you are now carrying a fix for this in the
ubuntu package. Would you mind posting the following patches to et-mgmt-tools:

patches/show_session_or_system_in_console.diff
patches/ssh_tunnel_username.patch
patches/restore_saved_images.patch
patches/save_separate_connection.patch

Thanks

Comment 2 Soren Hansen 2008-03-23 17:05:53 EDT
ssh_tunnel_username.patch was already submitted and applied (revision 
675:49c55daf788d).
I'll send the other ones. Thanks for the nudge :)
Comment 3 Soren Hansen 2008-03-30 13:09:48 EDT
I sent a patch to fix this bug to the mailing list and it has now been applied.
(Changeset  734: 2ea7f77b0339)

I'm not too familiar with your bug handling policies, so I don't know if it's
appropriate to close this bug (since it's not in a release of any sort yet), so
I'll leave that up to you guys.
Comment 4 Daniel Berrange 2008-03-30 14:10:07 EDT
Patch is upstream, will incorporate into next release. Leaving this bug open
until its released.

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=2ea7f77b0339
Comment 5 Bug Zapper 2008-05-14 01:58:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Fedora Update System 2008-12-01 13:10:22 EST
virt-manager-0.6.0-0.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/virt-manager-0.6.0-0.fc9
Comment 7 Fedora Update System 2008-12-01 13:22:56 EST
virt-manager-0.6.0-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/virt-manager-0.6.0-1.fc9
Comment 8 Fedora Update System 2008-12-02 20:29:45 EST
virt-manager-0.6.0-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10705
Comment 9 Fedora Update System 2008-12-21 03:26:48 EST
virt-manager-0.6.0-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.