Bug 437135 - Firefox crashes in SSL/NSPR
Firefox crashes in SSL/NSPR
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firefox (Show other bugs)
5.1
i386 Linux
high Severity high
: rc
: ---
Assigned To: Gecko Maintainer
desktop-bugs@redhat.com
:
Depends On: 433823
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 11:57 EDT by Martin Stransky
Modified: 2008-05-29 09:32 EDT (History)
12 users (show)

See Also:
Fixed In Version: RHEL-5.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 09:32:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
back trace (5.62 KB, text/plain)
2008-03-12 11:57 EDT, Martin Stransky
no flags Details
another back trace (6.16 KB, text/plain)
2008-03-12 11:58 EDT, Martin Stransky
no flags Details

  None (edit)
Description Martin Stransky 2008-03-12 11:57:18 EDT
This bug is derived from Bug 433823.

Firefox crashes somewhere in NSPR/NSS.
Comment 1 Martin Stransky 2008-03-12 11:57:18 EDT
Created attachment 297796 [details]
back trace
Comment 2 Martin Stransky 2008-03-12 11:58:04 EDT
Created attachment 297797 [details]
another back trace
Comment 3 Kai Engert (:kaie) 2008-04-01 14:43:37 EDT
Are these really crashes?

I only see SIGPIPE?
Comment 4 Martin Stransky 2008-04-01 16:14:06 EDT
I can't reproduce it but it looks like the problem, doesn't it?
Comment 5 Kai Engert (:kaie) 2008-04-01 17:07:22 EDT
I'm surprised to hear that we crash because of SIGPIPE, I would have assumed the
application has signal handlers installed.

I don't see any stack that would indicate error handling.
The stacks look like normal operation.
Comment 6 Martin Stransky 2008-05-29 09:32:04 EDT
Should be fixed by the RHEL-5.2 update.

Note You need to log in before you can comment on or make changes to this bug.