Bug 437151 - Missing utilities due to chmlib configure pb
Missing utilities due to chmlib configure pb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: chmlib (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 13:15 EDT by Thierry Lelegard
Modified: 2008-05-10 09:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.39-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-10 09:56:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to chmlib.spec (418 bytes, patch)
2008-03-12 13:15 EDT, Thierry Lelegard
no flags Details | Diff

  None (edit)
Description Thierry Lelegard 2008-03-12 13:15:32 EDT
This enhancement request relates to package chmlib-0.39-5.fc8

Context
-------
The package chmlib, as delivered with Fedora, does not contain a few
utilities which are present on other distributions. These chmlib utilities
are used by other utilities like chm2pdf (not yet included in Fedora).

The most commonly used missing tool is extract_chmLib.

As a result, software like chm2pdf are reported as broken on Fedora
(while OK on Debian or Ubuntu).

Solution
--------
The solution is quite simple: run chmlib's configure with
option --enable-examples

This option generates the following additional utilities, to be included
in chmlib package:

/usr/bin/chm_http
/usr/bin/enum_chmLib
/usr/bin/enumdir_chmLib
/usr/bin/extract_chmLib
/usr/bin/test_chmLib

Patch
-----
The attached patch against chmlib.spec includes the missing utilities:
- add option --enable-examples in configure
- add generated files from /usr/bin in package
Comment 1 Thierry Lelegard 2008-03-12 13:15:32 EDT
Created attachment 297807 [details]
Patch to chmlib.spec
Comment 2 Patrice Dumas 2008-03-18 09:16:42 EDT
looks good to me.

I'd prefer to have chm_http in a separate package, together with
one of the enum since both do the same.

I contacted the debian packager to ask him to avoid patching the 
sources such that it is easier to use his patch.
Comment 3 Peter Lemenkov 2008-03-18 09:29:04 EDT
Agree - we need to recompile it woth utilities support. Unfortunately my access
to Fedora's buildsystem is limited now so I can't do it by myself in the nearest
future.

Patrice, could you, please, fix spec-files and rebuild chmlib?
Comment 4 Fedora Update System 2008-03-29 08:37:43 EDT
chmlib-0.39-7.fc7 has been submitted as an update for Fedora 7
Comment 5 Fedora Update System 2008-03-29 08:39:08 EDT
chmlib-0.39-7.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-04-01 17:36:13 EDT
chmlib-0.39-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update chmlib'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2858
Comment 7 Fedora Update System 2008-05-10 09:56:33 EDT
chmlib-0.39-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.