Bug 437155 - mail-notification crashes on login
mail-notification crashes on login
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 13:27 EDT by Jonathan Kamens
Modified: 2008-03-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 12:50:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug buddy report (287.84 KB, text/plain)
2008-03-12 13:27 EDT, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2008-03-12 13:27:42 EDT
Mail-notification crashed when I logged in.  I got both an error dialog and a
bug buddy report (attached).  As far as I can tell, I am *not* running two
copies of mail-notification.

Here's the error dialog text:

A fatal error has occurred in Mail Notification
A Bonobo exception (Unknown CORBA exception id:
'IDL:omg.org/CORBA/COMM_FAILURE:1.0') has
occurred in
GNOME:MailNotification:Automation:hasMailboxes().

When I restarted mail-notification by hand, it worked.

I have mail-notification-5.0-3.fc9.i386, and all of my other packages are
up-to-date with Rawhide.
Comment 1 Jonathan Kamens 2008-03-12 13:27:42 EDT
Created attachment 297812 [details]
bug buddy report
Comment 2 Dmitry Butskoy 2008-03-13 11:00:31 EDT
Is it an initial install of mail-notification, or an update?

What is your mailbox type? (Local, or pop3, imap etc.)
Comment 3 Jonathan Kamens 2008-03-13 11:07:54 EDT
Update.
Two IMAP mailboxes (one is back-ended by Exchange, one by cyrus imapd).
Comment 4 Dmitry Butskoy 2008-03-13 11:17:17 EDT
Try to remove mail-notification from the panel, and then add it "from the
scratch" (as with initial install), prroviding the same configuration...
Comment 5 Thorsten Leemhuis 2008-03-13 13:02:27 EDT
(In reply to comment #0)
> Mail-notification crashed when I logged in. [...]

We had one or two reports from people where the session daemon started
mail-notification twice which resulted in a crash. 

Wild guess: Maybe it's the same problem in this case?
Comment 6 Jonathan Kamens 2008-03-13 13:08:34 EDT
<grumble>
I read those other reports before submitting mine.  Which part of, "As far as I 
can tell, I am *not* running two copies of mail-notification," did you not 
understand.
</grumble>
Comment 7 Thorsten Leemhuis 2008-03-13 13:24:15 EDT
Sorry, I just tried to be helpful. I read the report when in a hurry and offline
and when I saw another comment 24 hours later I just remembered that I had a 
"ask him if there accidentally might be to copies" on my internal todolist.

IOW: I wasted my time and not you ;-)
Comment 8 Dmitry Butskoy 2008-03-13 13:35:19 EDT
> As far as I can tell, I am *not* running two copies of mail-notification.

Jonathan,

Is mail-notification listed in
Main Manu->System->Preferenses->Personal->Sessions ?
If listed, what options it is invoked with?

How you invoke it manually then -- from the Desktop menu or from the command line?
Comment 9 Jonathan Kamens 2008-03-14 13:53:18 EDT
There is something weird going on here.  It might be a GNOME issue rather than a
mail-notification issue.

I opened the Sessions control panel and unchecked "Mail Notification" from the
Startup Programs" tab.  Then I right-clicked on the mail-notification icon and
removed it from the notification area.  Then I confirmed that it wasn't running.
 Then I went to the Session Options tab, clicked the Remember button, and waited
for it to indicate that it had saved the session.  Then I closed the control
panel and logged out.

When I logged back in, mail-notification started up again!  I checked, and it
was in fact unchecked in the Startup Programs tab.

Then I went to the Current Session tab and found it listed there.  I highlighted
it and hit the Remove button, then cleared it from the notification area again,
then saved my session again, then logged out and logged back in again.  This
time, it didn't start.

Then, I enabled "Mail Notification" in the "Startup Programs" tab, logged out
and logged back in again, and it started successfully.

Perhaps I *was* running two copies of it, one because of the checked box on the
"Startup Programs" tab, and one because it was listed in the "Current Session"
tab to be restarted upon login.  Is there a problem with how mail-notification
instantiates itself, perhaps?  I just don't know what's going on here.
Comment 10 Dmitry Butskoy 2008-03-17 08:38:25 EDT
Well,
something like the previous "two copies" issues here...

Thorsten,
Did you already inform the upstream about that previous issues?
Comment 11 Dmitry Butskoy 2008-03-18 12:50:56 EDT
Upstream hopes that thiis will be fixed in the upcoming 5.1 version, since d-bus
will be used instead of bonobo.

Note You need to log in before you can comment on or make changes to this bug.