Bug 437199 - Timer ISR: Time went backwards messages
Timer ISR: Time went backwards messages
Status: CLOSED DUPLICATE of bug 437252
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
i386 Linux
medium Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
: 437640 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2008-03-12 16:20 EDT by Marcelo Giles
Modified: 2008-03-18 16:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-18 16:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg output (59.56 KB, text/plain)
2008-03-12 16:23 EDT, Marcelo Giles
no flags Details
xm dmesg output (4.75 KB, text/plain)
2008-03-12 16:24 EDT, Marcelo Giles
no flags Details

  None (edit)
Description Marcelo Giles 2008-03-12 16:20:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008030315 Red Hat/3.0b4pre-0.beta3.4.el5 Minefield/3.0b4pre

Description of problem:
After updating from RHEL 5.1 (kernel-xen-2.6.18-53.1.13.el5) to RHEL 5.2 beta (kernel-xen-2.6.18-84.el5), I get several (hundreds) of the following kernel messages:

Mar 12 16:24:18 mgiles kernel: Timer ISR/0: Time went backwards: delta=-10322713 delta_cpu=245677287 shadow=13679511332 off=486180514 processed=14176000000 cpu_processed=13
Mar 12 16:24:18 mgiles kernel:  0: 13920000000
Mar 12 16:24:18 mgiles kernel:  1: 14176000000

Machine gets slow to a crawl and becomes unresponsive, /var/log/messages gets filled with these messages.

Machine type: Lenovo ThinkPad T60.

I tried (as suggested) chkconfig cpuspeed off and reboot, but did not make any difference.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot machine with xen kernel 2.6.18-84
2. run dmesg or cat /var/log/messages to chek for Timer ISR messages

Actual Results:

Expected Results:

Additional info:
Similar to BZ #222973
Comment 1 Marcelo Giles 2008-03-12 16:23:38 EDT
Created attachment 297838 [details]
dmesg output
Comment 2 Marcelo Giles 2008-03-12 16:24:27 EDT
Created attachment 297839 [details]
xm dmesg output
Comment 3 Bill Burns 2008-03-15 16:53:07 EDT
*** Bug 437640 has been marked as a duplicate of this bug. ***
Comment 4 Bill Burns 2008-03-15 16:54:23 EDT
I have isolated this to starting with the -65 kernel. -64 HV&kernel work fine
and -65 fails. Tried the -65 HV with -64 kernel and all was well. Don't know
which patch introduced this yet. 
Comment 5 Bill Burns 2008-03-16 06:47:44 EDT
Actually this failure starts somwehere after the -68 kernel, which works. -70
does not work. I was confusing this with another problem.
Comment 6 Bill Burns 2008-03-18 16:24:56 EDT
Marking this as a duplicate, even though it was filed first, as the other bug
has already been posted.

*** This bug has been marked as a duplicate of 437252 ***

Note You need to log in before you can comment on or make changes to this bug.