Bug 437201 - iSCSI - missing CHAP support in Anaconda
iSCSI - missing CHAP support in Anaconda
Status: CLOSED DUPLICATE of bug 432819
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
All All
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 16:33 EDT by IBM Bug Proxy
Modified: 2008-04-18 10:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 10:24:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add CHAP support to Anaconda (20.07 KB, text/plain)
2008-03-12 16:33 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 43092 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-03-12 16:33:39 EDT
=Comment: #0=================================================
L. C. McDermott <mcdermoc@us.ibm.com> - 2008-03-12 15:46 EDT
See Red Hat BZ 307761.

This BZ is being opened to track inclusion of patch attached to 307761, which
missed RHEL5.2.

=====================================================================================================
Redhat 

BTW, this patch is missing kickstart support.  We need the community to help 
us out here so that we don't regress anything.


=Comment: #3=================================================
L. C. McDermott <mcdermoc@us.ibm.com> - 2008-03-12 15:59 EDT
This bug was opened because of the confusion surrounding multiple issues being
addressed by Red Hat feature bugzilla 307761 - iSCSI Boot Firmware Table tool
support [anaconda]. iBFT support was added to RHEL5.2, however, CHAP support was
missing. Red Hat decided that adding the Anaconda CHAP support was too risky and
deferred this to RHEL5.3. Comments from original bug:

 [edit]
latest version of the anaconda patch


Comment #39 From Mark Hamzy (hamzy@us.ibm.com) 	on 2008-02-19 15:59 EST 	[reply] 	 

All that is missing from the anaconda patch on 2/12 is support for the reverse 
chap username/password in kickstart.  I was asking for help from 
redhat/kickstart community because I didn't want to break anything.


Comment #40 From Martin Sivák (msivak@redhat.com) 	on 2008-02-20 04:46 EST 
[reply] 	 

Unfortunately it is too late to push the reverse CHAP stuff into 5.2. The best
way how to push it into 5.3 is to fill a new bug, which will get approval for
next release. After that we can start working on incorporating it into the RHEL
tree.
Comment 1 IBM Bug Proxy 2008-03-12 16:33:42 EDT
Created attachment 297841 [details]
Add CHAP support to Anaconda
Comment 2 Joel Andres Granados 2008-04-18 10:24:20 EDT

*** This bug has been marked as a duplicate of 432819 ***

Note You need to log in before you can comment on or make changes to this bug.