Bug 437204 - persistent guests (save guest at shutdown and reload it at boot)
persistent guests (save guest at shutdown and reload it at boot)
Status: CLOSED DUPLICATE of bug 444273
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 17:02 EDT by syntron
Modified: 2009-01-22 08:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 08:09:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description syntron 2008-03-12 17:02:33 EDT
Description of problem:

libvirt can save and restore guests. It is also possible to autostart guest at 
boot time. I miss a similar option: 'persistent'

booting the host:
* the guest is restored if there is a saved version
* else it is booted

shutdown of the host
* the guest is saved

The xendomain script does something like this. There the 'autostart' option 
checks if the domain was saved. If it was this domain is restored else it is 
created. At shutdown of the dom0 all running domU's are saved.
Comment 1 Daniel Veillard 2008-03-17 04:33:57 EDT
Adding extra features like this are better discussed in the mailing-list.
I don't think a bugzilla entry has enough visibility to get the amount
of eyeball and review needed for this kind of things especially since it
toutches things like the boot sequence. So please bring it up to the
mailing-list for discussions:

    https://www.redhat.com/mailman/listinfo/libvir-list

Daniel
Comment 2 Bug Zapper 2008-05-14 02:00:14 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Daniel Berrange 2009-01-22 08:09:19 EST

*** This bug has been marked as a duplicate of bug 444273 ***

Note You need to log in before you can comment on or make changes to this bug.