Bug 437217 - Can't install via virt-install (missing 'fedora.css')
Can't install via virt-install (missing 'fedora.css')
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-virtinst (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 18:33 EDT by Thomas DuBuisson
Modified: 2008-06-12 16:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-12 16:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas DuBuisson 2008-03-12 18:33:00 EDT
Description of problem:
It is not possible to install Rawhide as a guest OS (Xen DomU) using
virt-install.  At the very least, rawhide is missing the 'fedora.css' in its os
tree.

Version-Release number of selected component (if applicable):


How reproducible:
Consistent

Steps to Reproduce:
1. sudo virt-install -n test -r 512 --vcpus=1 -f /var/lib/xen/images/RH.img
--vnc -p -b virbr0 -l "http://mirrors.kernel.org/fedora/development/i386/os/"

Alternatively, you can use virt-manger if you like a GUI.
  
Actual results:

$ sudo virt-install -n test -r 512 --vcpus=1 -f /var/lib/xen/images/RH.img --vnc
-p -b virbr0 -l "http://mirrors.kernel.org/fedora/development/i386/os/"
How large would you like the disk (/var/lib/xen/images/RH.img) to be (in
gigabytes)? 8  

Starting install...
libvir: Xen Daemon error : GET operation failed: 
[... a long time delay here as it tries to find out what type of distro this
mirror serves ...]
Could not find an installable distribution at:
http://mirrors.kernel.org/fedora/development/i386/os/
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start test'; otherwise, please
 restart your installation.
Wed, 12 Mar 2008 18:36:50 ERROR    Could not find an installable distribution
at: http://mirrors.kernel.org/fedora/development/i386/os/
Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 517, in <module>
    main()
  File "/usr/sbin/virt-install", line 481, in main
    dom = guest.start_install(conscb,progresscb)
  File "/usr/lib/python2.5/site-packages/virtinst/Guest.py", line 811, in
start_install
    self._prepare_install(meter)
  File "/usr/lib/python2.5/site-packages/virtinst/ParaVirtGuest.py", line 56, in
_prepare_install
    self._installer.prepare(guest = self, meter = meter)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 205,
in prepare
    
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 175,
in _prepare_kernel_and_initrd
    self.install["kernel"] = kernelfn
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 95, in
acquireKernel
    return store.acquireKernel(fetcher, progresscb)
  File "/usr/lib/python2.5/site-packages/virtinst/DistroManager.py", line 81, in
_storeForDistro
    
ValueError: Could not find an installable distribution at:
http://mirrors.kernel.org/fedora/development/i386/os/



Expected results:
Installation of rawhide should start in a VNC window.

Additional info:
Shouldn't matter, but the host is FC8 running the current Xen package (a Xen 3.1
derivative + Linux 2.6.21).
Comment 1 Thomas DuBuisson 2008-03-12 21:06:03 EDT
This is just a check in OSDistro.py that is a bit overly restrictive. 
'fedora.css' is just used to determine if the location is a fedora os tree.  The
check should either be fixed to work with rawhide (ex: look for a file that
exists )or fedora.css should be included in rawhide.
Comment 2 Daniel Berrange 2008-03-12 23:30:49 EDT
What version of the python-virtinst RPM do you have. This problem was fixed in
the python-virtinst 0.300.3 released to rawhide yesterday.
Comment 3 Thomas DuBuisson 2008-03-12 23:48:48 EDT
I'm behind the times what with using F8 as Dom0 and just trying to test rawhide
via Xen DomU.  Closing this bogus report now.
Comment 4 Daniel Berrange 2008-03-13 07:38:04 EDT
Re-opening because we need to ensure F9 DomU can be installed on an F8 dom0,
since F9 will not initially support Xen dom0 functionality.
Comment 5 Thomas DuBuisson 2008-03-15 20:33:38 EDT
Oh, and to answer your question, I have python-virtinst 300.2.  So good
solutions would either be releasing 0.300.3 for F8 or adding the fedora.css file
to the repo.

It should be noted that this won't fix F9/rawhide PVMs GUI install.  The vnc
window doesn't open for rawhide when installing in GUI mode - perhaps there is a
missing driver (xenfb?) in the rawhide initrd.  Can't find a bug report - if I
don't hear about one I'll create it.
Comment 6 Cole Robinson 2008-06-12 16:05:02 EDT
I've verified that F8 can detect and install an F9 tree correctly, so I'm
closing this as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.