Bug 437242 - nfsstat displays information about NFSv4 when it should not
nfsstat displays information about NFSv4 when it should not
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.1
All Linux
low Severity low
: rc
: ---
Assigned To: Steve Dickson
: Patch
Depends On:
Blocks: 391501 409971
  Show dependency treegraph
 
Reported: 2008-03-13 00:49 EDT by Andrew Ryan
Modified: 2010-10-22 19:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:01:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
correct cltv4info size and man page (1.36 KB, patch)
2008-03-13 00:49 EDT, David Robinson
no flags Details | Diff

  None (edit)
Description David Robinson 2008-03-13 00:49:42 EDT
Description of problem:
nfsstat(8) says "The default is to only print information about the versions of
NFS that have non-zero counts.", however information about NFSv4 is shown
regardless.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.9-24.el5

How reproducible:
100%

Steps to Reproduce:
1. mount some-nfsv3-server:/test /mnt # just so NFSv3 has some stats
2. nfsstat
  
Actual results:

# nfsstat 
Server rpc stats:
calls      badcalls   badauth    badclnt    xdrcall
64         0          0          0          0       

Server nfs v2:
null         getattr      setattr      root         lookup       readlink     
16      100% 0         0% 0         0% 0         0% 0         0% 0         0% 
read         wrcache      write        create       remove       rename       
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
link         symlink      mkdir        rmdir        readdir      fsstat       
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 

Server nfs v3:
null         getattr      setattr      lookup       access       readlink     
23       47% 9        18% 0         0% 0         0% 2         4% 0         0% 
read         write        create       mkdir        symlink      mknod        
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
remove       rmdir        rename       link         readdir      readdirplus  
0         0% 0         0% 0         0% 0         0% 0         0% 2         4% 
fsstat       fsinfo       pathconf     commit       
3         6% 9        18% 0         0% 0         0% 

Client rpc stats:
calls      retrans    authrefrsh
745        0          0       

Client nfs v3:
null         getattr      setattr      lookup       access       readlink     
0         0% 114      15% 7         0% 13        1% 29        3% 0         0% 
read         write        create       mkdir        symlink      mknod        
524      70% 6         0% 6         0% 0         0% 0         0% 0         0% 
remove       rmdir        rename       link         readdir      readdirplus  
5         0% 0         0% 1         0% 0         0% 0         0% 24        3% 
fsstat       fsinfo       pathconf     commit       
13        1% 2         0% 0         0% 0         0%

Client nfs v4:
null         read         write        commit       open         open_conf    
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
open_noat    open_dgrd    close        setattr      fsinfo       renew        
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
setclntid    confirm      lock         lockt        locku        access       
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
getattr      lookup       lookup_root  remove       rename       link         
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
symlink      create       pathconf     statfs       readlink     readdir      
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
server_caps  delegreturn  
0         0% 0         0%

(notice that NFS v4 details are shown here, but they're all zeros)

Expected results:

# nfsstat 
Server rpc stats:
calls      badcalls   badauth    badclnt    xdrcall
64         0          0          0          0       

Server nfs v2:
null         getattr      setattr      root         lookup       readlink     
16      100% 0         0% 0         0% 0         0% 0         0% 0         0% 
read         wrcache      write        create       remove       rename       
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
link         symlink      mkdir        rmdir        readdir      fsstat       
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 

Server nfs v3:
null         getattr      setattr      lookup       access       readlink     
23       47% 9        18% 0         0% 0         0% 2         4% 0         0% 
read         write        create       mkdir        symlink      mknod        
0         0% 0         0% 0         0% 0         0% 0         0% 0         0% 
remove       rmdir        rename       link         readdir      readdirplus  
0         0% 0         0% 0         0% 0         0% 0         0% 2         4% 
fsstat       fsinfo       pathconf     commit       
3         6% 9        18% 0         0% 0         0% 

Client rpc stats:
calls      retrans    authrefrsh
745        0          0       

Client nfs v3:
null         getattr      setattr      lookup       access       readlink     
0         0% 114      15% 7         0% 13        1% 29        3% 0         0% 
read         write        create       mkdir        symlink      mknod        
524      70% 6         0% 6         0% 0         0% 0         0% 0         0% 
remove       rmdir        rename       link         readdir      readdirplus  
5         0% 0         0% 1         0% 0         0% 0         0% 24        3% 
fsstat       fsinfo       pathconf     commit       
13        1% 2         0% 0         0% 0         0%

(notice that there are no NFS v4 details shown)

Additional info:

Patch to correct the problem is attached. The patch also adds the text "The
default is to only print information about the versions of NFS that have
non-zero counts." to each option in the man page.
Comment 1 David Robinson 2008-03-13 00:49:43 EDT
Created attachment 297892 [details]
correct cltv4info size and man page
Comment 2 RHEL Product and Program Management 2008-06-02 16:13:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Steve Dickson 2008-09-17 11:39:07 EDT
Fixed nfs-utils-1.0.9-36.el5
Comment 9 errata-xmlrpc 2009-01-20 16:01:48 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0107.html

Note You need to log in before you can comment on or make changes to this bug.