Bug 437258 - Flash not working with Firefox 3 beta
Flash not working with Firefox 3 beta
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Dennis Gregorovic
Daniel Riek
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 05:48 EDT by Alexander Todorov
Modified: 2008-05-21 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEA-2008-0436
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:41:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-03-13 05:48:22 EDT
Description of problem:
Flash is not working with FF 3 beta even when flash-plugin is installed.

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta3.4.el5
flash-plugin-9.0.115.0-1.el5

How reproducible:
100%

Steps to Reproduce:
1. Install firefox 3 beta (or RHEL 5.2 beta)
2. Install flash-plugin from the supplementary cd
3. Visit a website that has flash
  
Actual results:
Flash objects are not displayed

Expected results:
Flash objects are displayed

Additional info:
This is on x86_64 system with flash-plugin and firefox for i386 when running the
32bit version of firefox. That setup used to work on RHEL5 U1.
Comment 1 Alexander Todorov 2008-03-13 05:50:06 EDT
In steps to reproduce:
3. Run the 32bit version of Firefox (e.g. /usr/lib/firefox-3.0b4pre/firefox)
Comment 2 Matěj Cepl 2008-03-13 05:59:58 EDT
The answer is simple -- don't use firefox-32, but instead install
nspluginwrapper (both x86_64 and i386 packages). Then flash-plugin works even
with firefox.x86_64

firefox.i386 was bad hack which was never officially supported, isn't supported,
and with the advent of nspluginwrapper it is quite certain that it won't be
supported.
Comment 3 Alexander Todorov 2008-03-13 06:21:26 EDT
RHEL 5.2 x86_64 repo has nspluginwrapper.x86_64 only. 
Additionally it still has firefox 32/64 bit packages which means that 32bit is
still supported.

I'm hitting another bug with the 64bit version of FF3 and I'm not able to verify
your workaround at the moment.
Comment 5 Alexander Todorov 2008-03-13 06:40:06 EDT
(In reply to comment #2)
> The answer is simple -- don't use firefox-32, but instead install
> nspluginwrapper (both x86_64 and i386 packages). Then flash-plugin works even
> with firefox.x86_64
> 

firefox.x86_64 with nspluginwrapper.x86_64 and flash-plugin.i386 - not working.
nspluginwrapper.i386 not available in x86_64 repo
Comment 6 Matěj Cepl 2008-03-13 10:40:04 EDT
(In reply to comment #5)
> firefox.x86_64 with nspluginwrapper.x86_64 and flash-plugin.i386 - not working.

Not that nspluginwrapper is not workaround anymore but the official solution
from upstream.

> nspluginwrapper.i386 not available in x86_64 repo

OK, THAT is a bug. I will investigate what to do about it.

Matej
Comment 9 Michal Babej 2008-03-14 07:04:21 EDT
firefox.x86_64 with nspluginwrapper.i386 and flash-plugin.i386 - works for me. 

Now i'm not sure what sense does it make to have firefox.i386 in x86_64 tree... :)
Comment 13 Matěj Cepl 2008-03-14 13:16:37 EDT
OK, reassigning.
Comment 16 Dennis Gregorovic 2008-03-14 13:47:45 EDT
Can someone clarify the list of i386/x86_64 firefox/nspluginwrapper packages
should be in the x86_64 tree?  Thanks.
Comment 17 Alexander Todorov 2008-03-14 13:55:40 EDT
both 32 and 64bit versions of both packages unless FF.i386 is removed for some
reason depending on why it was added to the repo.
Comment 19 Dennis Gregorovic 2008-03-18 13:40:49 EDT
change committed in distill and should show up in the next set of trees.
Comment 23 errata-xmlrpc 2008-05-21 11:41:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0436.html

Note You need to log in before you can comment on or make changes to this bug.