This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 437284 - Reversed MAC adress after resume with forcedeth module
Reversed MAC adress after resume with forcedeth module
Status: CLOSED DUPLICATE of bug 428035
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 07:44 EDT by Michal Ingeli
Modified: 2008-03-13 16:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 16:17:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Ingeli 2008-03-13 07:44:16 EDT
Description of problem:

After every resume, direction of chars in mac address is toggled. So interface
name is changing from ethX to ethY and back after next resume. I also need to
reload module after resume.

Device:
00:08.0 Bridge: nVidia Corporation MCP55 Ethernet (rev a2)

ifconfig:
eth2      Link encap:Ethernet  HWaddr 50:A0:BB:17:16:00  
and
eth1      Link encap:Ethernet  HWaddr 00:16:17:bb:a0:50  

/etc/udev/rules.d/70-persistent-net.rules:

# nVidia Corporation MCP55 Ethernet
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="00:16:17:bb:a0:50", ATTR{type}=="1", NAME="eth1"
# PCI device 0x10de:0x0373 (forcedeth)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="50:a0:bb:17:16:00", ATTR{type}=="1", NAME="eth2"


Version-Release number of selected component (if applicable):

Linux bingo 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 17:48:34 EST 2008 i686 athlon
i386 GNU/Linux

How reproducible:


Steps to Reproduce:
1. hibernate
2. resume
3. checkinterface
1. hibernate
2. resume
3. checkinterface
  
Actual results:
MAC address is reversing between resumes

Expected results:
MAC address wont change between resumes

Additional info:
Comment 1 Chuck Ebbert 2008-03-13 16:17:37 EDT

*** This bug has been marked as a duplicate of 428035 ***

Note You need to log in before you can comment on or make changes to this bug.