Bug 437293 - Frysk crashes when debugging simple testing program [NEEDINFO]
Frysk crashes when debugging simple testing program
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgtk-java (Show other bugs)
5.1
All Linux
medium Severity high
: rc
: ---
Assigned To: Stepan Kasal
:
Depends On: 328531
Blocks: 173278
  Show dependency treegraph
 
Reported: 2008-03-13 09:05 EDT by Andrew Cagney
Modified: 2014-06-02 09:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:03:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (cagney)


Attachments (Terms of Use)

  None (edit)
Description Andrew Cagney 2008-03-13 09:05:17 EDT
+++ This bug was initially created as a clone of Bug #328531 +++

Description of problem:
when trying to debug (in debugging mode) this minimal C code:

#include <stdio.h>
#include <unistd.h>

int main () {
    for (;;) {
        sleep(1);
        puts("x");
    }
}

frysk crashes with this on stdout/stderr:

[matej@viklef] $ frysk       
java.lang.Exception: (for origin information, set GTK_DEBUG): failed to retrieve
property `GtkTreeView::odd-row-color' of type `GdkColor' from rc file value
"((GString*) 0x882ae20)" of type `GString'
   at org.gnu.glib.GObject.printStackTrace(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.gtk_main(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main(libgtkjava-2.8.so)
   at frysk.gui.Gui.gui(frysk)
   at frysk.bindir.frysk.main(frysk)
Exception in thread "main" java.lang.NullPointerException
   at org.gnu.gtk.Gtk.gtk_main(libgtkjava-2.8.so)
   at org.gnu.gtk.Gtk.main(libgtkjava-2.8.so)
   at frysk.gui.Gui.gui(frysk)
   at frysk.bindir.frysk.main(frysk)
Killed
[matej@viklef] $ 


Version-Release number of selected component (if applicable):
frysk-0.0.1.2007.09.24-1.fc8
frysk-gnome-0.0.1.2007.09.24-1.fc8

How reproducible:
frysk either freezes or crashes -- tried three times with either of these results.

Steps to Reproduce:
1.run frysk
2.open session with running program above
3.(if not frozen already) push next button
  
Actual results:
frysk either crashes or if it gets to showing toolbar it freezes

Expected results:
stepping through the code

Additional info:
I am probably doing something very stupid, but I really don't see the way how to
make this work. I tried to use frysk for debugging of my pretty trivial utility,
but I haven't managed to do it. Could you please help me how to make this work?

-- Additional comment from cagney@redhat.com on 2008-03-13 08:24 EST --
frysk -> libgtk-java; and owner -> sami.  I believe a libgtk-java update
addressed this specific issue.
Comment 1 Andrew Cagney 2008-03-13 09:13:08 EDT
This bug causes the frysk-gnome interface to crash within a short period of
time.  A fix is available and has been in use for ~month.

Risk of applying the change: Low.
The old code is clearly wrong; clients such as frysk relying on it will become
more stable.

Risk of not applying this change: Moderate.
The only client to so far identify this as a problem is frysk; and frysk's gnome
interface is in tech-preview.  Not applying the change will mean frysk's gnome
interface continues to be relatively unstable.

Cost of applying change: Requires QE.
Frysk can help with testing of this if needed.
The frysk group will help prepare the rpm.
Comment 4 Andrew Cagney 2008-03-20 09:31:19 EDT
Clearing flags; patch found to make frysk overall less stable on rhel 5.2.  Sami
identifying root cause.
Comment 6 RHEL Product and Program Management 2014-03-07 08:35:29 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 7 RHEL Product and Program Management 2014-06-02 09:03:46 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.