Bug 437294 - azureus hangs with "loading please wait"
azureus hangs with "loading please wait"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 09:09 EDT by Bruce Brackbill
Modified: 2008-03-13 10:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 10:01:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attachment of starting azureus from the terminal (9.41 KB, application/octet-stream)
2008-03-13 09:11 EDT, Bruce Brackbill
no flags Details

  None (edit)
Description Bruce Brackbill 2008-03-13 09:09:54 EDT
Description of problem:
Start azureus and it hangs/crashes with the message "loading please wait"

Version-Release number of selected component (if applicable):
azureus-3.0.3.4-6.fc8
libswt3-gtk2-3.3.0-31.fc8
libgtk-java-2.8.7-6.fc8
libgtk-java-2.8.7-6.fc8
java-1.5.0-gcj-1.5.0.0-17.fc8
tzdata-java-2007k-2.fc8
glib-java-0.2.6-10.fc8
java-1.7.0-icedtea-plugin-1.7.0.0-0.19.b21.snapshot.fc8
cairo-java-1.0.5-8.fc8
java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8
java_cup-0.10-0.k.6jpp.1
libgconf-java-2.12.4-9.fc8
firefox-2.0.0.12-1.fc8
firefox3-3.0-0.beta4.20080307.fc8.remi

How reproducible:
Start azureus and it hangs with the message "loading please wait"

Expected results:
azureus runs 

Additional info:
Starting azureus from the terminal i see the following error:
Browser: org.eclipse.swt.SWTError: No more handles
(java.lang.UnsatisfiedLinkError: no swt-mozilla-gtk-3346 or swt-mozilla-gtk in
swt.library.path, java.library.path or the jar file)
Browser: org.eclipse.swt.SWTError: No more handles
(java.lang.UnsatisfiedLinkError: no swt-mozilla-gtk-3346 or swt-mozilla-gtk in
swt.library.path, java.library.path or the jar file)
Browser: org.eclipse.swt.SWTError: No more handles
(java.lang.UnsatisfiedLinkError: no swt-mozilla-gtk-3346 or swt-mozilla-gtk in
swt.library.path, java.library.path or the jar file)
skin init took 2501ms
Comment 1 Bruce Brackbill 2008-03-13 09:11:11 EDT
Created attachment 297932 [details]
attachment of starting azureus from the terminal
Comment 2 Bruce Brackbill 2008-03-13 09:51:45 EDT
Maybe this version of azureus doesn't work with firefox 2 ?

Looking at this azureus Debian bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452322 

I happen to have xulrunner-1.9-0.beta4.20080307.fc8.remi installed so i tried
changing GRE_PATH to:
GRE_PATH="/usr/lib/xulrunner-1.9pre"

...and this change appears to be a successful workaround since azureus is
starting up now.
Comment 3 Lillian Angel 2008-03-13 10:00:52 EDT
Yes, This is fixed in azureus in rawhide. The version in f8 will only work with
Firefox 2.0.0.10

Note You need to log in before you can comment on or make changes to this bug.