Bug 437306 - dependency forthe "ant" package is missing by default.
dependency forthe "ant" package is missing by default.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Permaine Cheung
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-13 10:36 EDT by Håkan Lindqvist
Modified: 2008-03-14 08:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 08:16:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Håkan Lindqvist 2008-03-13 10:36:17 EDT
Description of problem:
Ant fails to run due to missing dependency after install.


Version-Release number of selected component (if applicable):
Apache Ant version 1.7.0 compiled on August 16 2007


How reproducible:
Install the ant utility.


Steps to Reproduce:
1.
yum -y install ant
ant
/usr/bin/build-classpath: error: Could not find xml-commons-apis Java extension
for this JVM
/usr/bin/build-classpath: error: Some specified jars were not found
Buildfile: build.xml does not exist!

  
Actual results:


Expected results:


Additional info:
Mitigation is to install dependency:

yum -y install  xml-commons-apis.i386
ant
Buildfile: build.xml does not exist!
Build failed

So adding that package as a dependency for ant should solve the issue.
Comment 1 Permaine Cheung 2008-03-14 08:16:30 EDT
Ant is running and is complaining that there's no build.xml.
I checked the latest ant package in F8, and it does Requires xml-commons-apis as
a dependency.

Note You need to log in before you can comment on or make changes to this bug.